Can't connect to Pi over WiFi

I can’t ping or telnet into my Raspberry Pi3 over WiFi but I can connect just fine over Ethernet.
Is the issue with my router or a setting in OSMC?

I’m trying to connect from a wired PC. Both devices are on the 192.168.1.x subnet through an ASUS RT-AC3200 router.

Hi,

Telnet is not installed by default, try ssh:

ssh osmc@192.168.1.x default password osmc.

As for pinging unless your router has some strange rules in place for your lan, are you able to ping other devices on your network?

There is nothing in osmc by default which would prevent responding to ping, unless you’ve installed something like ip tables? even then a rule would have to in place; double check the ip of your pi.

Thanks Tom.

I meant SSH. I use putty.

SSH and ping work when the Ethernet cable is connected and enabled. If I disable wired lan and enable WiFi (in MyOSMC) I connect and get an IP address. The Pi can access the internet and update the library and do system updates but I can’t ping it. It says host unreachable.

Hi,

Sorry to state the obvious but the pi will have a different IP on wifi to wired, unless you are using a static IP?

Thanks Tom.

Yes, I know. I’m using the correct IP address each time.

I just re-booted my router and it seems to be working now.

Hi,

Apologies I just wanted to make sure that wasn’t the case first.

You could try connecting a keyboard to your pi and access the local console and make sure you can ping your router over the wifi from the pi, details can be found here:

https://osmc.tv/wiki/general/accessing-the-command-line/

Also some logs while connected to wifi, may help:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.

Yeah, thanks. I hadn’t thought of that.

it working fine now but when it was bad, I could ping the Pi from the router admin page and it worked but I couldn’t ping the Pi from a wired PC.
Probably some routing issue within the router. The re-boot fixed it.

Thanks again,
Joe

Hi,

Glad to hear its sorted,

Tom.