Can't connect to WiFi

I have already found many similar posts here but none resolved my problem.

I have installed OSMC-10/2015-release on a raspberry 2 mode B. I am new to KODI, OSMC and Raspberry. I have a computer dual booted with Windows and Debian with which can I ssh to OSMC. I am not very fond of CMD or Terminal, but with a little help I can do whatever is required. I do not have USB keyboard currently, but a USB mouse is available.

My aim is to connect Raspberry Pi with OSMC installed (henceforth OSMC) to our Home Network wirelessly.

I brought a Raspberry Kit with WiFi adapter that’s been confirmed working well with Raspberry 2 (OpenELEC and Raspbian installed. I first used Openelec and the problem was there too. I will check Raspbian later.) Anyway, that WiFi adapter is Ralink MiniPC WiF adaptor; it’s chipset is realtek.
It can connect to the home network if I plug it to my PC.

I first connected OSMC to the internet via Ethernet and updated the system. Then I plugged in the WiFi adapter and disabled wired connection. My home network was detected by OSMC straightaway. I selected it and typed the passphrase. A message appeared showing connection was failed. I temporarily made my network open and tried connecting to it. Failed again. Then I headed over to here and found suggestions similar to this. It’s essentially about configuring WiFi through terminal using connman (Connection Manager?). It also failed. The strangest thing (IMO) is, I can get OSMC to connect to hotspots.

My modem is this which is Modem+WiFi Router.

We’re going to need some logs.

grab-logs -A
from an SSH session

or upload them via the Log Uploader in My OSMC.

How to submit a useful support request

Could you please explain how to use grab-logs -A.

What I have done: enabled debugging in OSMC. Rebooted. Tried connecting to WiFi network. disabled debugging. Pasted the content of /home/osmc/.kodi/temp/kodi.log here

If you’re using Windows, download and install this:

Use Putty to connect to osmc. Username and password are both osmc

Once you’re connected just type in grab-logs -A

That will give you a URL that you post here. Unfortunately the kodi.log isn’t going to have any info on a wifi problem, I think.

Yeah, I have putty installed.

grab-logs -A


grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
Unable to write temporary log to /var/tmp/uploadlog.txt

Should I enable debugging or something…

Means you have never installed any updates.

This is not good. It either means you’re completely out of disk space or the root file system is mounted read-only due to corruption. Either way this will be causing you problems elsewhere.

Can you post the output of these two commands:

df -h

Sorry for that. I had updated it but after many tweaks on wireless settings, decided to do a fresh install. Will update again, this won’t solve it, I assure you.

df -h

gave this:

/dev/root 7.0G 616M 6.0G 10% /
devtmpfs 363M 0 363M 0% /dev
tmpfs 367M 0 367M 0% /dev/shm
tmpfs 367M 5.0M 362M 2% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 367M 0 367M 0% /sys/fs/cgroup
/dev/mmcblk0p1 240M 17M 223M 8% /boot
/dev/sda1 3.8G 448K 3.8G 1% /media/ADATA
tmpfs 74M 0 74M 0% /run/user/1000



gave this:

/dev/mmcblk0p2 on / type ext4 (rw,noatime,stripe=1024,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=371328k,nr_inodes=92832,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=23,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
sysfs on /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq type sysfs (rw,nosuid,nodev,noexec,relatime)
/dev/sda1 on /media/ADATA type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0111,dmask=0000,allow_utime=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,errors=remount-ro,uhelper=udisks)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=75128k,mode=700,uid=1000,gid=1000)


sudo grab-logs -A

gave me

update: the problem is even there in Raspbian Jessie. Is there any known Router-setting Raspberry is not compatible with?

I’m not an expert at reading logs but it looks like your WLAN is being recognized and is attempting to connect and failing to authenticate.

Are you using MAC address filtering, maybe? You sure you got the password right? Try using some different security methods on your router. ie. WEP <=> WPA

I had disabled the password for a while and tried with no luck, maybe, I should do a log of that or something? And I had reset my router multiple times…

Open up your network and reboot both your router and osmc. Not sure how quickly osmc notices a network no longer requires authentication.

If logging in fails then, do grab-logs -A again.

The effect was almost immediate. The lock besides SSID all at once changes to an unlocked state. And no passphrase asked.

I see lots of timeouts attempting to associate with the router:

Nov 05 17:20:26 osmc wpa_supplicant[310]: wlan0: SME: Trying to authenticate with 48:ee:0c:db:15:ed (SSID='Amrutha' freq=2452 MHz)
Nov 05 17:20:26 osmc kernel: wlan0: authenticate with 48:ee:0c:db:15:ed
Nov 05 17:20:26 osmc kernel: wlan0: send auth to 48:ee:0c:db:15:ed (try 1/3)
Nov 05 17:20:26 osmc wpa_supplicant[310]: wlan0: Trying to associate with 48:ee:0c:db:15:ed (SSID='Amrutha' freq=2452 MHz)
Nov 05 17:20:26 osmc kernel: wlan0: authenticated
Nov 05 17:20:26 osmc kernel: wlan0: associate with 48:ee:0c:db:15:ed (try 1/3)
Nov 05 17:20:27 osmc kernel: wlan0: associate with 48:ee:0c:db:15:ed (try 2/3)
Nov 05 17:20:27 osmc kernel: wlan0: associate with 48:ee:0c:db:15:ed (try 3/3)
Nov 05 17:20:27 osmc kernel: wlan0: association with 48:ee:0c:db:15:ed timed out

Typically this would either be because the saved password is wrong, the router is blocking the client (mac address filtering etc) or because the signal is too weak.

How far is the Pi from your router ? If its not in the same room can you try temporarily bringing it into the same room to see if it then connects ? If it does, the issue is the signal is too weak, or there could be interference from other wifi routers in neighbouring properties. (In which case changing the routers channel might help)

If that doesn’t help, try completely forgetting the network and re-adding it in the network GUI.

Being that you just changed the wifi configuration on the router, forgetting the network sounds like a super idea to me. :wink:

It’s hardly two meters apart. I have opened up the network. There is no other WiFi networks. Router is at it’s default settings ( May be I should write to the manufacturer?)

I didn’t get the joke :pensive: Sorry for being too exacting, would you mind telling me how to make OSMC forget the network. And channel! I can change that? How will I do it? (Okay now I got the idea, but there is not a single WiFi network to worry about. So I don’t need to worry about channel also?)

I’ve never used wifi on my Pi but I’d think that there would be a button to forget a network you’d previously connected to. Can you open up the context menu with your wifi network highlighted maybe?

No context menu, right click gives me nothing. I have written to the Modem support team, but not very sure they can help. Thanks for your support :slight_smile:

To forget a previously saved Wifi network, go to the network name in the list, select it, and choose Disconnect and Forget.