Can't connect via SSH

I can’t seem to connect to two of my four Vero 4K units via SSH. This something I rarely do, but when I do it has always been to the two units I can connect to and I’ve never had an issue. I’m not certain I’ve ever connected to the two that I now see don’t work. But I can say that these two are rarely used and in fact I recently updated them to the July update as both were behind (one had June, the other had May).

Here’s the response I get:

Failed to startup SSH session: kex error : no match for method mac algo client->server: server [hmac-sha2-512-etm@openssh.com,hmac-sha2-256-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-512,hmac-sha2-256,umac-128@openssh.com], client [hmac-sha1]

BTW, this is a pop-up dialog from Remmina running under Linux.

I tried uninstalling SSH from the OSMC store, and it said it failed. I rebooted and installed it with no error. I note that under the OSMC addon I can no longer select Services. I mean I can highlight it and select it, but it never opens.

What next?

Cheers,
Robert

Hi,

ssh client in remmina is probably out of date, I would use the ssh client from your linux distro; from the terminal/ command line:

ssh osmc@ip.of.vero4k

If not already installed method will depend on distro, for example if you’re on debian:

sudo apt-get install openssh-client

If you still wish to use remmina, you will need to see if your distro provides an update.

This would suggest the 2 you can connect to are out of date.

try issuing:

sudo apt-get install --reinstall ssh-app-osmc

If that doesn’t resolve the issue, I would suggest backing up your settings and re-installing osmc.

Thanks Tom.

Remmina is up to date on my workstation and it works 100% on two of the four Vero 4Ks, always has.

The two Vero 4Ks I can and have always been able to connect to (and always using Remmina) are up to date and are always kept up to date, within a day or two of a new OSMC update.

Yet you’re saying that the two that are working are the problem? The two that I CAN get to the Services view under the OSMC addon and have never given me issues connecting to… are the problem. Huh.

Good idea, though, trying the SSH CLI in Linux - it connects to the problem units.
But sudo apt-get install --reinstall ssh-app-osmc made zero difference. I still can’t access the Services item under the OSMC addon and I still can’t connect with the Remmina client.

It’s not that I’m stuck on using Remmina, although I use it for a variety of things and its been good. But why the difference between the Vero 4K units when they are all the same? I’ve never installed or edited anything from the CLI, other than now wanting to mount an NFS share. So the only thing that has updated any of them is OSMC’s own updates. So if I can use Remmina for two, why not the other two?

Cheers,
Robert

Hi,

Could you please provide logs:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

One for one of units where remmina is working and one for a unit which isn’t working.

Also if you produce a debug log showing the issue in myosmc, that would help as well.

Thanks Tom.

Yep.

One that works fine:

  • Enabled debug, rebooted, connected with Remmina and ran an ls command and uploaded logs.

Working

One that doesn’t work:

  • Enabled debug, rebooted, tried to connect with Remmina (failed), opened OSMC addon and selected Services (it didn’t open), uploaded logs.

Not Working

Cheers,
Robert

I assume they have been setup at different times.
Run the following command on a working and a not working version and provide the URL.
paste-log /etc/ssh/sshd_config

Yes, they were set up on different dates, but I assume when OSMC updates them all that would render them all the same, with respect to anything underneath KODI (assuming I didn’t tinker under the covers, and I didn’t).

Working One

Not Working

Cheers,
Robert

Yes and no, generally everything will be brought up to date. But config files are treated differently and if modifications are assumed they are not updated.

As you can see if you compare the two files the setting of the not working one for HostKey is different.

You could change that to the one of the working one but be reminded that the setting of the non working one actually is more updated and more safe.
So ideally using an proper SSH client that supports the keys would be preferred

Ok, that makes some sense to me although I don’t know what I could have done to the working one that would be considered a modification as I’ve only ever used SSH to view things.

I think I would prefer to have them all working under the newest versions. If that means no longer using Reminna as my client, so be it. How do I update the older ones - through the OSMC addon or via the command Tom sent earlier?

Also, any idea why the ones with the newer SSH package would not open the Services view under the OSMC addon?

Cheers,
Robert

How are you authenticating? Public/Private keys?

I run Linux Mint and just tried Reminna and it seems to work on all my systems. I have version 1.2.0-rcgit-29

Just checking on best advice how to sync the files, will come back to you.

That is strange and should be another issue, suggest you open new thread for that.

As @bmillham wrote it seems you are using an older version of remmina. I found this remark on their webpage (How to install Remmina - Remmina)
“If you want to connect to more securely configured SSH servers on Ubuntu 16.04 and below, you have to upgrade libssh to 0.7.X. This can be achieved by adding the following PPA containing libssh 0.7.X by David Kedves and upgrading your packages:”

No, I normally just select the Password option. I tried the Public key (automatic) setting but that doesn’t work for any of my Vero systems.

I’m using Mint also. According to the “About” page, Remmina is version 1.1.2 and Mint Software Manager claims it’s 1.1.2-3ubuntu1. So I assume you manually added yours from outside the repository. I may well try that once I’ve standardized my OSMC SSH Server versions. Thanks for the input @bmillham

Cheers,
Robert

That’s the version that showed up when I looked in the software manager. I’m on Mint 19. I also checked on my other laptop that is a fresh install of Mint 19 and Software Manager also shows 1.2.0-rcgit-29, so that is the version Mint 19 users will get.

Public/Private keys work fine for me. You did do ssh-copy-id correct? If you get the keys working from command line, they will work in Remmina.

I did notice a problem that will prevent me from actually using Remmina. X forwarding doesn’t work properly. I know that doesn’t make any difference for what we are talking about, but it prevents me from using it.

@Phydeaux

Didn’t come up with a hotfix, for the time being my suggestion is to copy the file from the non working one (which is the correct one) to the working one.
Login the non-working one and execute scp /etc/ssh/sshd_config <IP Address of working one>:.
This copies it on the working one into the home directory
Then login the working one and execute sudo mv sshd_config /etc/ssh/ after that execute sudo systemctl restart sshd

Sounds good fzinken, there’s no big rush on this.

Interesting. OK, I’ll bite. I installed the libssh referred to in that note and tried again. Zero difference. So I also just did an update of Remmina outside of the normal Mint software channel, directly from the Remmina website. I’m now using version 1.2.31.2 and that does work with all my Vero 4K devices. So both the libssh and the version increment of Remmina are needed.

Still wanting to insure all my Vero 4K units are running the most recent versions of SSH. And once they are I’ll post a new support request if the Services item of the OSMC addon still won’t open.

Cheers to @fzinken and @bmillham ! @Tom_Doyle too, he must be feeling vindicated…
Robert

1 Like

I hope you still know which ones didn’t work before. Then you can follow my steps I wrote above.

Yes, aware of which ones are which, they are correctly named and have their IPs assigned…

Done.

1st Old one
2nd Old one

1st New one
2nd New one

Robert

Congrats, looks good

Good to know that we found the issue. We’ve seen this many times with Putty, but I think it’s the first time with a linux client. Probably because most of us just open a terminal and ssh into the other system.

Yep, very happy to have a handle on the issue, I expect it will be minor to update the SSH on the two systems. Meantime an updated Remmina is working fine. But now that I’ve been forced to just use the Linux command line client… it’s kinda faster than click, type, click, type for Remmina. But the big benefit is that I can copy/paste within a Linux terminal, whereas in the Remmina SSH terminal not so much. Surely there is a configuration Im missing to do that, but yeah. Linux teminal quicker.

Cheers,
Robert