Can't edit files on RPi HDD from Windows 10 machine

#1

Hey. Longtime lurker but just created an account for this problem I’m having.

I run OSMC on a RPi 3 B+. I also have a windows 10 machine from which I can see the hard drive attached to my RPi (its how I move content from my laptop to the RPi/HDD).

Recently OSMC updated to 18.2-RC1 and since then I seem to have lost “write” privileges on my RPI HDD.

Previously, I used Samba to find my RPi on my network. If I wanted to edit a subtitle (for example) I’d just double click the shortcut on my desktop, navigate to the file on the RPI HDD, edit and save. After the update, I can see and read any file on the RPi HDD, I can even play files from the Rpi HDD on my windows machine, but I can’t add anything to the HDD or make any changes. Windows gives an error saying that I don’t have the correct permissions so I’m guessing something changed in the update (before it worked fine). If I connect the HD locally to my machine I can do all that, no problem.

As I said before, I’m using Samba for and pre-update, this was working… Thanks for any help you can give!

#2

Are you connecting to the windows machine with a user and password from that machine? Windows now requires this.

#3

I thought I was. When I originally set up the shortcut on my desktop, I told it to save credentials. But in any case I remapped the RPi HD to my computer as the Z drive and now the process is: Login to windows with U/N and P/W, click on shortcut to the RPi HD, enter the RPI U/N & P/W, and I’m in.

From there it looks like I have read and execute permissions on all the files, but I can’t write to any of them