Can't find 120GB Drive. Tried Fat32/NTFS/exFat

Hi, I have a SSD with my Music and I want to play the music with OSMC, but it doens’t mount my SSD. What could be theProblem?

More information required please.

I assume it is a USB connected drive ? How are you checking to see if it has mounted ?

An automount drive should appear under /media. Please provide a copy of the system journal and APT logs after booting with the drive attached, which you can do from the My OSMC log uploader.

It’s a 2,5" SSD with a SATA to USB Adapter.

I look if it’s can see it under Music > Add Music… > Root/media/


i also tried and “sudo fdisk -l”

There’s nothing in the log at all about a USB hard drive - I see a mouse and a Wireless adaptor but no other USB devices detected.

This is most likely a power issue - are you trying to power the drive directly from the Pi ?

If so have you added usb_max_current=1 to config.txt ?

Can you try it via a powered USB hub ? Or can you try it without the mouse and wireless adaptor connected ? Some wireless adaptors use a lot of power such that you may not be able to power both a hard drive and wireless adaptor from the Pi.