Can't find after last update

Updated my RPi-3 today. But not found (according to systemd journal). It does show up with “ldconfig -p”, but smbd, nmbd, and mediacenter system services won’t start (i get :frowning_face: for the latter). And again, with journalctl, I keep seeing the error:

/usr/lib/kodi/kodi.bin: error while loading shared libraries: cannot open shared object file: No such file or directory

I did “apt-get update”, and then “apt-get dist-upgrade”, but still the same.

I’d rather not reinstall osmc from scratch. Please Help.



Logs would help, but my guess is that you should backup and re-install (on a new SD card) as your SD card is probably failing.

Some SD cards are not genuine or have a lower capacity than advertised. Some simply fail over time.

Symptoms of SD cards not working correctly are:

  • Read-only behaviour, or changes made not persisting
  • A filesystem corruption error

Symptoms of counterfeit SD cards are:

  • Writing works until a certain filesystem size is reached, thereafter, writes seem to cause issues where existing data is lost or newly written data is not preserved.
  • SD card fails after a short amount of time.

Counterfeit cards are usually found on Amazon and eBay.

SD cards have a limited lifespan. I recommend you change SD card and suspect that issues will no longer persist with a good card. If you would like to be a good quality SD card purpose manufactured for OSMC, then you can find one in the Store.

I’m wary that the problem is the SD card. It is a Samsung EVO which have been very reliable for me.

The filesystem is not corrupted. I ran e2fsck on it with no errors.

The only log available is the systemd log. kodi logs aren’t created, since mediacenter won’t start. And the error in the systemd log is what I originally posted: “can’t find”

And this only happened after the latest update. is installed (the link to the actual libsamba library, as wll as the acutal lib itsef.) ldconfig finds it.


Check md5sum md5sum /usr/lib/arm-linux-gnueabihf/ | paste-log
And size/date ls -lah /usr/lib/arm-linux-gnueabihf/ | paste-log

Provide URL of both outcomes

md5sum /usr/lib/arm-linux-gnueabihf/ | paste-log

ls -lah /usr/lib/arm-linux-gnueabihf/ | paste-log

md5sum looks wrong, should be d538bdf436ef785f1a6b65b81cbfc0ca

Can you post ls -lah /usr/lib/arm-linux-gnueabihf/

ls -lah /usr/lib/arm-linux-gnueabihf/ | paste-log

Well size of the file looks ok, but as the md5sum differs it points quite likely to a filesystem/SD Card issue.
You could try to reinstall samba-libs and see if you get same md5sum afterwards. Otherwise new install on new SD Card recommended.

How do I reinstall samba? I’m a redhat/fedora guy, and really only know yum/dnf.

btw, thx for the help.


sudo apt-get install --reinstall samba-libs

okay. re-installing samba worked.

I still am hesitant to believe the SD card got corrupted after the osmc update. Especially since I ran e2fsck on it (on another system), which found no errors.

I will see about copying this to a new card, just in case.

thx again.


SD cards normally fail with write errors, so failing after an update makes sense.