Can't get 4k to work

Somewhat. SSH it not enabled on the box.

Yes

Duly noted.

If you have a USB keyboard and hold CTRL during boot, you may be able to get to a console.
Then I’d do rm -rf /home/osmc/.kodi. This will cause Kodi to recreate all settings on first-run.

Failing that, a reinstall is the easiest option and will only take 2-3 mins.

Thanks for the super fast support :slight_smile:
I’ll report back.

2 Likes

Pressing ctrl on boot didn’t show the console.
I connected it to a computer monitor where it displayed the standard linux boot screen. But the screen was flickering, and the boot never completed. It just looped.
After trying and failing several times with the micro sd cards from my pi’s, i finally succeded in reinstalling with a usb stick.
After booting i had blue flickering lines all over the screen.

In conclusion: it seems my problem from the onset was the included cable was broken/bad.
The longer cables i bought does not seem to support 2160p either, correct?

Do you have any tips regarding getting plex to stream without transcoding? And displaying files in HDR/10bit.

The included cable and OSMC cable should both support a 4K resolution.

Something seems wrong here. Is Vero 4K plugged directly in to the wall?

Can you enable ssh and upload a set of logs?

We should resolve this before proceeding any further

Sam

Weird, it sure doesn’t for me :confused:

It was when i flashed the image and tested with the computer monitor. It’s now in a powerstrip.
The voltage is 224V RMS.
It’s connected to ethernet.

I’ll look at this sometime in the weekend. I’ve been ordered to leave “good enough” alone for now :wink:

For the record:
It’s now connected with the HDMI-cable i previously used for my pi. It’s outputting 4k bt.2020 video now.
The video ought to be 10 bit, but the AVR claims to get 8 bit. The TV does recognize it as HDR.
It works directly in the TV and through the amplifier.
I’ve applied the cache settings mentioned here:

I could understand one bad cable in the box. It’s going to happen to someone occasionally. But if you also bought a 2M HDMI cable from our Store then the odds are quite unlikely.

I remember your order specifically as it’s tough to fit the extra cable in the box.

Try direct temporarily.

Next update, I’m adding an Enable HDR setting for TVs that don’t advertise their capabilities automatically.
For now, you could put in /etc/rc.local before exit 0:

echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr

Sam

1 Like

That works! Thanks!

I got three 2m cables. They were quite tight :D. Thanks for the fast shipping by the way.

Log:
https://paste.osmc.tv/vunasuliqu
It’s from when i tried to play a video with 5.1 sound.
So i enabled debug logging - and i’ve gotten a bit farther in the debuging process.
I’ve been fiddling with the audio devices, when audio is set to “optimized” i get distortion i my sub and left rear speaker when starting something with 5.1 or more channels of sound.
“Best match” just seems to work.
“Fixed” shows no video.

Unfortunately it’s not a full set of logs so hard to speculate. Re: audio issues, try this hotfix:

Is there a guide ? The kodi debug log contains loads of personal plex info, which i’d rather not send.

I’ll check out the hotfix.

Edit: this only happens if passtrough is enabled.
optimized:
distortion in my surround back left speaker.
Best match:
loads of distortion in my surround left and surround right/surround right rear.

I’d assume it actually bitstreams, but doesn’t announce/set the mode correctly.
based on
[ 728.670418] aml_snd_m8_card aml_m8_snd.46: 8ch PCM output->notify HDMI

boot log including trying to play a file (best):
https://paste.osmc.tv/zojatixonu
Trying to play with optimized:
https://paste.osmc.tv/zuwozumejo

boot log:
https://paste.osmc.tv/yafuladoyu
As soon as i enable passtrough i get this error in the log:
https://paste.osmc.tv/ijiwaqexiy

No matter what audio options i choose my reciever always show PCM 7.1, when playing anything.

Is it normal for the display to flash partially pink when changing resolution, and on stop to have a blue/white progressbar visible ?

I’ve now had a few files where the problem arises, even if i have passtrough disabled. I’ve provided logs in a message to @sam_nazarko
A reboot of the 4k fixed it :confused:

Keep an eye on it and let me know if this happens again

Hi
I had the same problem again. This time with the exact same file. I’d just stopped it and turned the tv off (not the 4k).
When i turned the tv back on i had distortion in most of my speakers.
I’m sending you a log in a pm.

Log when playing from a SD-card, Plex uninstalled
Bitstream enabled, audio output configuration set to “Best match”
https://paste.osmc.tv/votogoreje
reciever reported 7.1 sound (ie. no bitstream).

This is with audio configuration set to optimized
https://paste.osmc.tv/uyuwabumow
reciever reported 7.1 sound (ie. no bitstream).

That red text looks mightily suspicious.


Playing same file bitstream disabled:
https://paste.osmc.tv/qurokoroya

What does this mean:
[ 160.170863] Sink is HDMI device
[ 160.170889] hdmitx: system: packet: can’t get vendor data

I might add that bitstream works with my laptop, and i’ve never had a problem playing 7.1 files from any of my Pi units. They didn’t have osmc installed tho.

Hi,

That looks fine. Logging is just a bit noisy.

Raspberry Pi doesn’t support passthrough of HD audio formats (i.e. 7.1). Audio would be sent as LPCM 7.1.

Can you take a quick photo of your audio settings?

18:13:57.597 T:4072666096   DEBUG: CAESinkALSA::GetChannelLayout - Input Channel Count: 2 Output Channel Count: 2
18:13:57.597 T:4072666096   DEBUG: CAESinkALSA::GetChannelLayout - Requested Layout: FL,FR
18:13:57.597 T:4072666096   DEBUG: CAESinkALSA::GetChannelLayout - Got Layout: FL,FR (ALSA: none)

Kodi isn’t attempting to use passthrough at all.

Do you have a small (20-30s) sample of the video?

Cheers

Sam

I’m not sure how to accomplish that, but the same happens on other files. It’s probably easier to use the demos.

This is a log of trying to play the dolby atmos helicopter demo, right after a reboot:
https://paste.osmc.tv/idudozegug

This is a log ~30 seconds later trying to play dolby-audiosphere. This resulted in massive distortion:
https://paste.osmc.tv/qagudelifo

Let me know if i can do anything to facilitate the debugging.
(Both of the above files are from one of the demo sites that are linked somewhere in this forum)