Can't get Atmos to work with soundbar/Vero 4k+


#1

I received my Vero 4k+ today and I love it. Delivery was swift and It plays all my files (even 60GB+ movies). However I can’t get Atmos to work with my setup. I want to point out that my TV/receiver is also brand new, so I’ve never tried Atmos content before I got my Vero either, so I’m not sure if this is a Vero issue or something else. My soundbar is NW-N950 and my TV is a QE75Q8FN.

  • The Vero is connected directly to my soundbar
  • The soundbars ARC HDMI is connected to my TV:s ARC HDMI
  • Passthrough is enabled in the Vero audio settings.

However in the settings of my soundbar Dolby Digital+ is grayed out. I can only chose Dolby Digital. The HDMI input audio format is set to Bitstream.

Any ideas? It has probably a very simple solution, I’m just very new to this…


#2

Hi

Can you upload a log via my osmc and send us the URL so we can confirm you enabled all of the necessary passthrough options?


#3

Cool! I just sent you the log.


#4

Hm, you writing “all of the necessary passthrough options” made me think, because I could only see 1 option that was related to that. I eyed through all the options really carefully one more time because of that, and I noticed that I could change “modes” in the audio menu in Vero to “expert” to enable more options. And there it was… I had to check a bunch of boxes to confirm that my receiver supports all the various audio formats - DTS etc. I guess there is a good reason those aren’t automatically checked in as default?

And now it works! I’m so happy and relived after hours of trouble shooting. Thanks a bunch Sam. Now I’m gonna enjoy my new rig :slight_smile:


#6

Glad to hear this!

Let us know if you need help with anything else