Can't get CEC remote to work with RPi2

I’ve just installed OSMC on an RPi2 and can’t get the TV remote to work OSMC’s interface.

I’m completely new to OSMC and the world of HTPCs so perhaps I’m just missing something obvious here…

I’ve connected my RPi2 with a Sony Bravia (model: kdl 32d3000). Tried two different HDMI inputs.
In the HDMI settings of my TV the RPi2 is recognised in the device list (recorder 1 AV7 (Kodi)).

I’ve also found ( an lirc conf file for my remote (RM-ED035). Which I’ve put in to /etc/lirc/. I then chose the RM-ED035.conf through the My OSMC > Remotes menu

A couple of reboots later, and many searches on forums, no luck.

Anything I should be doing differently?

Have you checked under Settings|System|Input Devices that CECis enabled?

Yes, it lists the CEC interface there. No options to enable or disable though?

There should be an option (click box / bright square …)

An yes, just noticed there’s a whole page of settings behind the CEC entry on the peripherals screen. It is enabled.

What’s curious is that after a reboot the ‘connected to HDMI device’ and ‘HDMI port number’ are not visible. When I restore the default settings on the CEC settings screen these two lines appear.

Connected to HDMI device: TV (other option available is amplifier/AVR device)
HDMI Port umber: 1

However, still no joy with the Sony remote.


Tried the complete power down and sequencing of power ups as described, but makes no difference I’m afraid.

The lirc stuff has absolutely nothing to do with CEC and none of that should have been necessary. Does CEC work on any other device connected to that tv?

Change the HDMI cable

Change of HDMI cable makes no difference either I’m afraid.

This is the only combo of HDMI connected devices in the house, so no options to try CEC on something else either.