Can't get IR remote to work... [Raspberry Pi][Solved]

I have this IR receiver:

Connected to the GPIO like this:

Which was taken from this tutorial

I’m using the MCE remote control by Hauppauge, this is the one:

When running these commands through SSH:
osmc@osmc:~$ sudo modprobe lirc_rpi
osmc@osmc:~$ sudo kill $(pidof lircd)
osmc@osmc:~$ mode2 -d /dev/lirc0

I can click on the remote and see a response:
space 16777215
pulse 2644
space 874
pulse 451
space 427
pulse 450
space 430
pulse 478
space 875
pulse 452

So the IR receiver and the remote control are both working.

When I issue this command:
osmc@osmc:~$ dmesg | grep lirc

I get this result:
[ 3.980599] lirc_dev: IR Remote Control driver registered, major 245
[ 3.983918] lirc_rpi: module is from the staging directory, the quality is unknown, you have been warned.
[ 4.226106] pinctrl-bcm2835 3f200000.gpio: pin gpio18 already requested by lirc_rpi; cannot claim for 3f203000.i2s
[ 4.943005] lirc_rpi: auto-detected active high receiver on GPIO pin 17
[ 4.943216] lirc_rpi lirc_rpi: lirc_dev: driver lirc_rpi registered at minor = 0
[ 4.943225] lirc_rpi: driver registered!
[ 5.102738] input: lircd as /devices/virtual/input/input0

Not sure about the pin 18 error in there.

[Continued in the next post]

… Continued … [This forum allows only 5 URLs per post for new users, sorry].

In OSMC, I’ve disabled CEC in the settings following this guide:

And enabled LIRC GPIO support (out_pin=17, in_pin=18, all default values).
Also, I’ve used the lircd.conf from this guide:

Tried enabling and disabling the RC6 option as well.

The remote doesn’t work in OSMC. Any ideas?

My logs:

Any suggestion will be highly appreciated…

I would say your problem is that you’re using the wrong lircd.conf. The one you have posted is for the little rectangular remote with the 3 red buttons along the top shown in the adafruit article at the top left - this remote is in no way similar to the Hauppauge remote that you have, so I’m not sure why you thought this would work ?

Silly question, but did you not try the Hauppauge profile (hauppage45-pvr350-lircd.conf) already built into OSMC ? That would probably work… if not, try rc6-mce-lircd.

Oh wow. Not sure what I was thinking or what I thought the config file I used would work…
The rc6-mce-lircd works great! Thanks!