Can't get my Vero4K+ above 100Mb/s ethernet speed

Hello, I am sure there is Something I missed here :wink:

I have just replaced my old Netgear 10/100Mb switch by a brand new Tenda SG108 10/10/1000Mb one, to get gigabit speed between my server and the Vero4K+.
But I can’t manage to have my Vero4K+ negociate 1000Mb speed…

Here is what I see when checking the link.

osmc@Vero4K:~$ sudo ethtool eth0 | grep Speed
        Speed: 100Mb/s
osmc@Vero4K:~$ sudo ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: on
        Supports Wake-on: ug
        Wake-on: d
        Current message level: 0x0000003d (61)
                               drv link timer ifdown ifup
        Link detected: yes
osmc@Vero4K:~$ uname -a
Linux Vero4K 3.14.29-156-osmc #1 SMP Tue Oct 15 20:21:25 UTC 2019 aarch64 GNU/Linux
osmc@Vero4K:~$ 

Obviously the Vero could achieve 1000BaseT, but for a reason negociation is stuck at 100BaseT.
I am using a 2meter CAT5e cable from Vero4K+ to the switch. Can this be my problem, must I get a Cat6 or 7 one ?

My desktop on the same switch with a new 15meter Cat7 cable was immediately renegociated at 1000Mb/s full duplex…

Thanks a lot for any advice !

PS/ I read a very long post on the forum about some faulty boxes in 2018 and/or erratic performance in the 300/500Mbs, but it is closed now. And my case is probably more some stupid configuration stuff on me as I don’t even get pass 100BaseT…

Try trading the Cat7 cable just to test it on the Vero.

As far as the Vero4K+ is concerned, the router is only advertising 100baseT/Full.

Perhaps a cable problem.

The faulty units have been dealt with and only affected a small number of units. They would negotiate at 1Gbit, but would get very poor performance in the TX direction.

All devices are tested before dispatch with an iperf3 test.

I’d try another cable and also reboot the switch. Sometimes my switch falls down to 100Mbps and the only solution is a reset.

Thanks a lot for such prompt answers!
A bit difficult to use my existing Cat7 cable (already routed…).
What I tried is with another 5e I had Handy, and also plug it directly on one free ADSL router slot instaed of the switch, but no luck.
I’ll try asap with a brand new cable and report back.

Try rebooting the switch / router.

It is entirely possible that $15 does not buy the highest quality eight port switch on the market. I’ve had very good luck with the TP-Link brand that don’t cost much more when I need something cheap. Regarding the category of the cable on a gigabit connection two meters long there is no benefit to anything more than Cat 5. It is entirely possible that you have a bad cable, but it being “only” cat 5e for gigabit is not the problem.

1 Like

So rebooting the switch did not solve it, but I managed to divert the Cat7 cable for a quick test (I know, CAT7 is a bit overkill…) and Bingo ! all fine, the box immediately negociate at gigabit :smile:
So I guess I just had a couple of very poor 5e cables. The Vero4K+ was not the problem here.
I’ll get a new cable and hopefully it should do the trick!
Thanks again for all advices

1 Like

Glad to hear a new cable solved this.

Confirming : new Cat6 cable installed yesterday and everything is fine, detected 1000BaseT end to end. Thx!

1 Like