Cant install Alpha4 onto RPi2


I have tried installing Alpha4 onto my RPi2 using the OSMC-Installer both on Windows and Ubuntu, and separately using Win32DiskImager.
Each time I get the rainbow pattern, missing device node at CPU 0-4 and it sits at 0% - “just a moment” for ages (at least 5 minutes) before erroring out with “install failed: could not mount bootfs”.
I am trying to install it to a 4gb microSD card.

I installed Raspbian onto the same microSD card absolutely fine, so I don’t think I’ve got a duff microSD card.

I don’t want to try OpenElec as I’ve been using RaspBMC since it started, but I would like to play with my new toy.

Any ideas,

You did select Raspberry Pi 2 in the drop down menu of the OSMC installer?

Yes, Raspberry PI 2 was selected

Maybe there are some problems with internet connectivity or Sam has some server problems so that it can’t download all the necessary packages…

It took me about 10min to post this, so yeah could be server problems :wink:

I’ve just tried again this morning and still nothing.
I am going to try different SD cards to see if that gets me anywhere.

Have you tried downloading this image
and selecting “use a local build on my computer” in the installer?

1 Like

I’m going to try this, as I’m having the same problem.

Just to update everyone…

I used a different microSD card (Transcend 4GB Class 6, instead of Class 2), used the image provided above, and a different power adapter… and it all worked.

I did notice that the power adapter that I had used originally (and I have gone back to), do cause the rainbow image to appear in the top right corner.

However, OpenElec and Raspbian both installed fine with that power supply and SD card.
I am just happy it is working now, so I’m not going to investigate further.