Can't install netatalk on OSMC on Raspberry Pi 2

Hi there,

I tried to install netatalk using sudo apt-get install netatalk, but it wouldn’t find the package.

I also tried manually, but it would never be on locations where it should, such as at init.d, and systemctl would not find it.

Could someone helping me out on how to do it? I have a Raspberry Pi 2 and the latest OSMC.

Thanks!

Did you sudo apt-get update before attempting the install command??

Personnally, before installation or upgrade, ALWAYS sudo apt-get update. Unless the last apt-get update has been since last reboot or less than 6hrs.

Yes, I did… Unfortunately it didn’t work.

That’s odd…

osmc@osmc:~$ apt-cache search netatalk
afpfs-ng-utils - Client for the Apple Filing Protocol (AFP) (utility programs)
gosa-plugin-netatalk - netatalk plugin for GOsa?
libafpclient-dev - Client for the Apple Filing Protocol (AFP) (development files)
libafpclient0 - Client for the Apple Filing Protocol (AFP) (shared library)
netatalk - AppleTalk user binaries
netatalk-dbg - Debug symbols for netatalk
python-reconfigure - simple config file management library
osmc@osmc:~$ sudo apt-get install netatalk
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libcrack2 libgdbm3 perl perl-modules
Suggested packages:
  texlive-base-bin groff quota db4.2-util perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl make libb-lint-perl
  libcpanplus-dist-build-perl libcpanplus-perl libfile-checktree-perl liblog-message-simple-perl liblog-message-perl
  libobject-accessor-perl
Recommended packages:
  cracklib-runtime lsof rc db-util libpam-cracklib rename libarchive-extract-perl libmodule-pluggable-perl libpod-latex-perl
  libterm-ui-perl libtext-soundex-perl libcgi-pm-perl libmodule-build-perl libpackage-constants-perl
The following NEW packages will be installed:
  libcrack2 libgdbm3 netatalk perl perl-modules
0 upgraded, 5 newly installed, 0 to remove and 7 not upgraded.
Need to get 5352 kB of archives.
After this operation, 30.1 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Check for connectivity issue on your end. It’s fine here…

This is weird… Mine reports this:

$ apt-cache search netatalk
gosa-plugin-netatalk - netatalk plugin for GOsa²
python-reconfigure - simple config file management library

Something must be missing!

If you are running OSMC 2015.06-1, then there are only 2 explanations here, either you aren’t running apt-get update to sync with the debian/raspbian apt repos, or you have a connectivity issue preventing that sync from occurring…

The weird thing is that I can install some packages, but not others. It is connecting fine, and I always update it before the install. Maybe I should add a repo?

I had to add no repo.

Please upload full logs via My OSMC, and contents of /etc/apt/sources.list.

S

I’ve sent all the logs. Don’t know if you can see they are the ones from my Pi. Let me know if I can provide more info.

You need to post the URL provided in the dialog here, otherwise we can’t access the logs.

My bad, I didn’t wait for the url. Here it is:

http://paste.osmc.io/exowomudev

Has this been resolved / fixed ?

I have exactly the same problem - fresh install of OSMC 2015.06-1

$ apt-cache search netatalk
gosa-plugin-netatalk - netatalk plugin for GOsa²
python-reconfigure - simple config file management library

I have made no changes to the repos.
Anything else I try to install installs OK, it’s just netatalk that’s a problem.

sources.list

deb http://ftp.debian.org/debian jessie main contrib non-free

deb Index of /debian jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv jessie main

Thanks,
Andy

It would appear that netatalk is not in the Debian Jessie repo.

Raspberry Pi 2 on OSMC uses Debian Jessie while Raspberry Pi 1 on OSMC use Raspbian Jessie.

The two do not have identical package versions or indeed even the same compliment of packages - there are packages that exist in only one or the other.

The below link seems to suggest that netatalk was present in Debian Wheezy (previous version) and will again be in Debian Sid (current unstable/testing) but is for some reason not in Debian Jessie:

https://packages.debian.org/search?keywords=netatalk

Also:

https://lists.debian.org/debian-devel/2014/11/msg00276.html

No luck yet? It’d be great to see this happening. I could use a nice way to transfer files between my Mac and osmc…

Not sure what you mean by no luck yet ?

Netatalk does not exist in the Debian Jessie repository as I already pointed out above. As OSMC is based on Debian Jessie that means that affects OSMC too as we are effectively a Debian derivative.

This is a policy/technical decision made by the Debian maintainers not by us, so until that changes there is not much we can do.

At the moment your only choice would be to download the netatalk source code and compile it yourself if you really need to use it - keep in mind that AFP (Apple Filing protocol) is now deprecated in favour of SMB - support for it is being removed from Kodi and even Mac OS X now uses SMB in preference to AFP and will eventually phase it out.

There is no reason why you can’t use SMB to transfer files between your Mac and OSMC.

1 Like

How to install AFP library in latest koid build. (Aug -30th) ?

You can install libafp, but Kodi is no longer compiled with AFP support

Sam

I don’t know about others, but it would be very nice if AFP support were included.
SMB works not so well with a Mac - at least it hasn’t been work great for me. Ejecting a volume almost never works well, it says it can’t eject the volume, but make it unusable until one disconnects from the network and reconnect again. AFP was really smooth, and worked like a charm back on the RaspBMC days…

Unfortunately AFP support was removed from Kodi upstream, so there is no easy way to add it back.

The reason it was removed is because it was broken and did not work properly anyway, and there were no developers maintaining the code. (Meaning the bugs would never get fixed and most likely more problems would occur over time)

You do realise that recent versions of Mac OS X actually use SMB natively from Mac to Mac and that Apple themselves have deprecated AFP as of the latest versions of Mac OS X ? (It will only fall back to using AFP when talking to other Mac running older versions of OS X)

Unfortunately the world moves on and Apple themselves have decided to phase out AFP. With Apple dropping support for AFP nobody is going to spend time and effort updating and fixing AFP support in Kodi.

What version of Mac OS are you having problems with with SMB ? I have not run into any issues connecting to Samba on OSMC from Snow Leopard, Mavericks, or Yosemite.

You are probably better to try to solve the issue connecting via SMB (or use NFS, which is supported natively in Mac OS) than holding out hope for AFP support which at best is on life support.

1 Like