Can't install OSMC on Pi3

Hi, I have a new Pi3 with new 32gig Sandisc. Raspbian worked out of the box, also had no probs when I tried OpenElec. I was informed OE was out of date & I should get OSMC. Tried each of the following steps multiple times:

–Windows installer: will not allow me to select what version to download (field is blank). I can only proceed if I select “load from local computer”. Which then gives me more non-specific error msgs. I can supposedly select online version if I fake out the installer: act like I’m going to select a build… then do not. Then I get this message: “You didn’t select a custom build - reverting to online build”. I select Wired Connection > SD card, etc. But then installer hangs on downloading screen & gives me error message - but no log files. (“An error occurred extracting the archive - please consult the logfile!” That error screen’s ‘back’ button is not clickable.) This has all happened multiple times. I searched computer thoroughly for log files each time: nothing. Used AgentRansack: still no log files.

–img file: tried to install by copying img file to Sandisc using Win32DiskImager. Reformatted Sandisc first so OSMC would not be competing with old version of OpenElec or Raspbian. Did not boot. Out of ideas.

I’ve looked elsewhere for help before registering, & at old “related” threads here. Thanks for any help.


I believe you also posted this over at Reddit.

A log file should be saved under C:\Users\YourName.

Can you screenshot the Windows installer?

Which version of Windows do you have?


Ty Sam, yes I did & was told to post it here. Running XP. Finally found log file (C:\Documents and Settings\HP_Administrator), it’s very long: tried to upload full logfile but .txt not authorized, pls advise. Didn’t want to paste into body of message & hog forum-space. :wink: Most frequent error sequence is:

Sat Feb 3 14:10:36 2018 SD installation selected
Sat Feb 3 14:10:38 2018 Installing usbit32 imaging binary to temporary path
Sat Feb 3 14:10:38 2018 Installing empty boot sector to temporary path
Sat Feb 3 14:10:38 2018 Installation was successful
Sat Feb 3 14:10:38 2018 Enumerating imageable devices for Windows
Sat Feb 3 14:10:38 2018 New disk device entry created with entry point F:, 30528MB free space and label
Sat Feb 3 14:10:41 2018 Device selected: 2764 F:\ 30528MB
Sat Feb 3 14:10:44 2018 EULA has been accepted
Sat Feb 3 14:10:44 2018 Extracting C:/Documents and
Settings/HP_Administrator/Desktop/Rasp Pi-related/OSMC_TGT_rbp1_20171102.img.gz
Sat Feb 3 14:10:44 2018 Could not open target file C:/Documents and
Settings/HP_Administrator/Desktop/Rasp Pi-related/OSMC_TGT_rbp1_20171102.img
Sat Feb 3 14:10:44 2018 Error string was Access is denied.

The first time I installed (before I’d reformatted & other systems were on the SD card) it seemed to almost work - it threw different errors, but did seem to install - but still didn’t boot:

Wed Jan 31 16:24:01 2018 Extracting C:/Documents and
Wed Jan 31 16:24:28 2018 Finished extraction. Going to write image Wed Jan 31
16:24:28 2018 Requesting confirmation from user
Wed Jan 31 16:24:31 2018 User confirmed
Wed Jan 31 16:24:31 2018 Workaround Windows 10 card protection
Wed Jan 31 16:24:31 2018 Writing 512 bytes to erase MBR
Wed Jan 31 16:24:31 2018 Could not trash MBR
Wed Jan 31 16:24:31 2018 Messages: stdout:
USB Image Tool 1.74

Last-ditch attempt (screenshot 4 ) : I extracted contents of IMG file with 7-Zip & tried copying to SD card, which of course didn’t work either. I’m sure I’m missing something dead obvious, but Idk what it is…

Ty again for your help! :slight_smile:OSMC_1


That’s strange.
Make sure the installer is running as an Administrator.

It looks like the SD card has been prepared correctly.

You are using the wrong image however. RBP1 is for Pi0/1, and won’t boot on a Pi2/Pi3.

Oh good grief! ;D Thanks so much, I misread the download page & grabbed the wrong IMG file. I’ll try again with a new img & report back.

Ok it’s installed! The next series of tries had the installer failing at ~70% & saying corrupted data, so I re-downloaded the IMG file. The Windows Installer failed to install again. I tried Win32DiskImager another time, & that seemed to do the trick. After the splash screen & successful installation announcement, I saw the little linux screen which said Waiting for root filesystem device, & then Recovering journal. Hopefully that’s normal. Then it booted. Now I just have to figure out where the log-off button is buried, lol.

Thanks very much indeed for the fast replies & your help! :slight_smile: