Can't install TVheadend?

#1

Hi All

running Vero4k+ with daily builds. Trying to install tvheadend from “OSMC appstore” and when clicking on it nothing happens. It’s just dead - cannot install it.

Ideas?

0 Likes

#2

In fact, when I go into appstore, nothing responds - can’t even scroll down to ftp server, transmission torrent client etc. THe only thing that responds is the BACK/RETURN button.

0 Likes

#3

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

0 Likes

#4

Done, my logs here.
https://paste.osmc.tv/tilagamuja

0 Likes

#5

deb http://download.osmc.tv/dev/gmc-19/public gmc-19 main

Does the issue occur in a stable release of osmc?

Thanks Tom.

0 Likes

#6

It used to be ok in 17.6 I think, yes.

0 Likes

#7

Hi,

I suspect this is down MyOSMC not running correctly on the unstable release path you are on. I suggest trying to install TVHeadend from the command line:

sudo apt-get update
sudo apt-get install armv7-tvheadend-app-osmc

Thanks Tom.

0 Likes

#8

Yes that worked, but I can’t configure it at all. Nothing shown in the TV Section, seems to be no way to configure it.
OSMC services menu is also not responding at all to any key presses except for back button. I can see the tvheadend service “running”, but that’s it.

0 Likes

#9

Are you running a nightly build of OSMC?

Sam

0 Likes

#11

Yes I am doing the nightlys.

0 Likes

#12

@gmc does my osmc need a bump in your repo?

0 Likes

#13

Part of what you just said was greek - but yes I guess so!! How does one do that…

0 Likes

#14

That’s for @gmc to do. Then it will be delivered as an update.

Sam

@gmc: please let me know what you bump to; so I can bump +1 for final.

0 Likes

#15

Will bump to 3.0.671 and include in the next nightly

0 Likes

#16

Yes that has worked - can now manipulate/install services and navigate app store.

Still can’t figure out how to work/configure with tvheadend…

0 Likes

#17

Glad to hear this.

I think we have a TVHeadend guide somewhere

Sam

0 Likes

#18

I cannot find any PVR clients (backend??) to add to populate the “pvr” or TV section. The kodi repository appears to have no clients that can be added on?

I have found how to work with tvheadend:
enter “youripaddress”:9981 in your browser.

0 Likes

#19

They are already installed. You simply have to enable the one you wish to use.

0 Likes

#20

How/where do i do that. There are no options in any menus that I can find.
I’ve tried using both the Kodi skin and the OSMC skin.

0 Likes

#21

In the add-on browser, under My add-ons.

0 Likes