Can't pair Bluetooth device with OSMC


I’m having an issue with pairing my iPod touch with OSMC on a raspberry pi2. I had read that some external Bluetooth adapters can be finicky, so I made sure that I got the official OSMC Bluetooth dongle.

Basically I went into MyOSMC/Network and then into the Bluetooth settings. Then I enabled the Bluetooth adapter and started discovery mode. It recognised my iPod, I then selected it and got the menu for Pair with Pin or Pair without Pin etc. I tried Pair with Pin first, my iPod asks me to enter a pin, but OSMC doesn’t tell me the pin to enter. So the pairing fails…

Then I tried Pair without Pin, and this also failed. Have I done something wrong or not enabled/downloaded an addon etc?

Debug log here:

I have just tried with an iPad as well.

Same steps as above, however when I selected Pair with Pin, nothing happened and the pairing failed. My device then no longer appears in the available devices box.

Debug log here:


Apologies for delay in responding to this, seemed to have missed this.

I’m not sure why isn’t working from the gui, you may have more success from the command line.

DBMandrake posted some instructions sometime back, which look good to me. They can be found here

I’ve seen your post in [TESTING] Bluetooth audio streaming (A2DP) (this is when I realised I missed your topic), I don’t think its related, as you are having issues with pairing, not testing A2DP. Once you’ve the pairing issue resolved, and you wish to test A2DP; I’m sure your feed back would be welcome.

I hope this helps.

Thanks Tom.

Thanks @Tom_Doyle for responding to my issue, no worries about the delay.

I will try the command line approach following the instructions in the link that you attached from DBMandrake when I get home and let you know how I go.

Thanks for the advice regarding the post in the other topic. Apologies I thought it might be related.

I’ll update here on how I go. Thanks for your help.

Hi @Tom_Doyle I just got the chance to have a go at connecting my devices using the command line process that you provided the link to. I’m happy to say that I have successfully been able to connect both my devices :slight_smile:. So thank you very much.

I am interested in playing music from my iPod or iPad to OSMC via Bluetooth (the reason I bought the Bluetooth adapter), however despite being connected to OSMC via bluetooth I don’t have the option to redirect my audio on either of my devices to OSMC. Is there a setting in OSMC that I need to adjust to allow me to “airplay” audio via Bluetooth? Just for reference, I have been able to play music to a portable Bluetooth speaker from my iPod so I know that the iPod has the capability to do this.

I think that this is related to A2DP… Is that right?

Any knowledge or help you can give me would be awesome! Thanks :slight_smile:

Did you install the A2DP package from the Testing thread?

No I haven’t. Thanks for the heads up. I’ll give that a go!