Can't play audio via Bluetooth Headphones

I’m trying to listen audio via my Ausdom ANC headphones. I’ve read some other topics about it, especially this one: [TESTING] Bluetooth audio streaming (A2DP)
But I can’t find any recent topic. What is the current status? I’ve installed that a2dp package, after that I was able to pair, but as soon as I play a video (via NFS) everything hangs/stutters. I hear no sound at all. Is there a workaround?

Is it headphones or headset? Headset will show two profiles and you would need to pick that respectively.
Search for a2dp headset here in Discourse, than you will find an explanation.

Headphones, not a head set. It shows AUSDOM Anc8 only once and the headphones show as connected.

I am not referring to Bluetooth profile but audio sink

Ah thank you! That has indeed solved the issue! Solution was in this post: Bluetooth fix for December update - #23 by Den4t

In short, I ran:

pactl list cards

Then indeed, the sink for my Bluetooth headphones was set to “headset_head_unit” and not “a2dp_sink”. After running:

pactl set-card-profile bluez_card.E8_07_BF_FB_F4_14 a2dp_sink

It worked! No lag so far.

This is pretty hardcore stuff, it would be awesome if this could be documented somewhere. I’ve spent quite some time browsing through all topics, I have no idea what everything means exactly, I just want it to work :slight_smile:

Thanks again @fzinken