Can't play avi/DIVX - black screen or loading forever


I’m using Vero 4K+ with the latest packages, therefore the latest Kodi release. I’m using Kodi for 10+ years now. It’s amazing, plays almost anything.

However after not using AVI/DIVX for 3/4 years, I tried to play something old, but it is unable to play it. When I try to play this old show, it flashes up black screen, then it pretends it’s playing but I gone back to menu. Then displays the loading circles, and doesn’t play it at all, the loading goes on forever.

It looks like it’s playing in the background, but if I just go to the 4 arrows option to return to the play from the menu (full_screen_button), it returns me to the player which seemingly playing the video, but there’s no sound, nor video.
I can seemingly use fast forward, or just skip forward. It’s also showing it’s caching the video as expected (the grey line increases…).

Everything else in eg. HEVC/MPEG/MKV/MP4 works fine, this is the only thing doesn’t seem to work. I can play these files fine via (mini)DLNA on my LG TV, the files are perfect.
I tried the same file on a vanilla Kodi installed on my Windows PC, it works all fine there.

I remember when I had Raspberry Pi, I had to do something extra to play these kind of videos, I imagine some kind of licence for this codec. Is this relevant on Vero 4K+?

Mediainfo output of one of the files of this show:

$ mediainfo myshow.avi
Complete name                            : myshow.avi
Format                                   : AVI
Format/Info                              : Audio Video Interleave
File size                                : 347 MiB
Duration                                 : 46 min 22 s
Overall bit rate                         : 1 046 kb/s
Writing library                          : VirtualDub build 13870/release

ID                                       : 0
Format                                   : MPEG-4 Visual
Format settings                          : BVOP
Format settings, BVOP                    : Yes
Format settings, QPel                    : No
Format settings, GMC                     : No warppoints
Format settings, Matrix                  : Default (H.263)
Codec ID                                 : DIVX
Codec ID/Info                            : Project Mayo
Codec ID/Hint                            : DivX 4
Duration                                 : 46 min 22 s
Bit rate                                 : 908 kb/s
Width                                    : 512 pixels
Height                                   : 384 pixels
Display aspect ratio                     : 4:3
Frame rate                               : 23.976 (24000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Compression mode                         : Lossy
Bits/(Pixel*Frame)                       : 0.193
Stream size                              : 301 MiB (87%)

ID                                       : 1
Format                                   : MPEG Audio
Format version                           : Version 1
Format profile                           : Layer 3
Format settings                          : Joint stereo / MS Stereo
Codec ID                                 : 55
Codec ID/Hint                            : MP3
Duration                                 : 46 min 22 s
Bit rate mode                            : Constant
Bit rate                                 : 128 kb/s
Channel(s)                               : 2 channels
Sampling rate                            : 44.1 kHz
Compression mode                         : Lossy
Stream size                              : 42.5 MiB (12%)
Alignment                                : Split across interleaves
Interleave, duration                     : 42  ms (1.00 video frame)
Interleave, preload duration             : 500  ms

Debug log (sanitised, let me know if you need certain lines of the original):
I took a note of the last line before I enabled the debug logging and tried to play this show. It was this:

2022-01-01 18:13:02.278 T:2715     INFO <general>: JSONRPC Server: New connection added

What can I do to make these work on Vero 4K+ too?

Thank you, Roland

Set hardware decoding to HD and up.