Can't play certain movies, error "Open - Error, could not open file /media/...", "ERROR: OpenDemuxStream - Error creating demuxer"

After checking mediainfo and seeing this, instead of a proper report, I started thinking…

mediainfo Gomorrah.2008.720p.Criterion.Bluray.DTS.x264-GCJM.mkv
Complete name : Gomorrah.2008.720p.Criterion.Bluray.DTS.x264-GCJM.mkv
File size : 2.74 GiB

Tried the disk on another computer and SURPRISE, all them failed.
The files were corrupted after all… sorry for doubting you, my gorgeous pi!
Leaving this in case someone searches for a similar issue. TRY THE FILE ON ANOTHER DEVICE!

Hey guys!
Cleared the logs, restarted, reproduced the error and upload logs:

Device: Raspberry Pi 2b
Installation media: SDHC class 10 card
Connection: Wifi
OSMC version: newest
XBMC version: Kodi, newest
Codecs: bought both
Audio/Video Output: HDMI
Overclocked: Yes, to the turbo default settings

Hope you can help me. The error is basically this “Open - Error, could not open file /media/Datos/Movies/Le.Prenom.2012.BDRip.720p.CINEMANIA.mkv”, “ERROR: OpenDemuxStream - Error creating demuxer”.

Is that an I/O error or could be missing codecs? Tried several files, I see no pattern, some work, some don’t, some are HD, some SD. Some .mvk, some .avi.
I bought the codecs for my Pi 2b, applied them and restarted.

Also, I copied a movie that was failing from the USB disk to the SD card, copied without any errors, but still couldn’t play from there.

Any ideas? Thanks for the help!

03:38:12 120.710335 T:1715246064 ERROR: Open - Error, could not open file /media/Datos/Movies/Senna (2010) [BluRay 720p][MULTi][WwW.ZoNaTorrent.CoM].mkv

This definelty shows that the file could not be open (physically) for whatever reason. I suggest:

  1. Enable debug logging
  2. Provide full logs not only Kodi (easiest with grab-logs -A)
  3. Provide mediainfo of the file with problem

Please see the mediainfo section in How to submit a useful support request - General - OSMC