Can't play network files, streaming works flawlessly

A great hello to everybody. I’m a long time crystalbuntu user who recently installed OSMC on both the ATV and raspberryPi. While the latter continues to work without any issue, the ATV recently stopped playing files hosted on my NAS. The two devices point to the same share on the NAS and even though they belong to different routers they both can physically access the files (e.g. browsing through the folders in the Video -> Files menu) but when confirming the file with the central remote button, the ATV shows the “waiting” indication in the lower right corner, then it disappears and nothing happens.
I thought it had something to do with the fact that I couldn’t finish the update, so I searched the forums to find a solution and did all the necessary steps to solve (fsck the boot partition etc) but still no steps ahead on the other issue.

Is there any log file I can verify to understand what prevents the ATV to work? As I mentioned in the subject, streaming videos off the internet (YouTube, vimeo) works great.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Maybe you are using DHCP and IP of your NAS changed. Avoid using hostnames as that is not always reliable.

As @fzinken says though, we need a log to see what the issue may be.

Sam

Thank you Sam and fzinken. I’ll try later to generate and send you the log.
Regarding the DHCP, I can already say that it isn’t, as all the actors involved have static IP (NAS, raspberry Pi and ATV)

Hello. Sorry for not getting back to you earlier but it was a very tough week :slight_smile:

I uploaded the logs here: http://paste.osmc.io/itawovetih

I reboot the ATV and tried to watch “Batman - The Movie” if this helps finding out the right point. In the meantime I am experiencing the same problem on the Rpi… :frowning: I noticed in the ATV logs that there is an error following the moment in which the video is supposedly going to be played and the error is “OpenDemuxStream - Error creating demuxer”, maybe you have some clue on what the whole thing is due to…

Thank you in advance.