Can't re pair remote to dongle

So been using CEC for a LOG time on my Vero 4K +, pulled out the remote that came with it and it no longer works, I put a new battery in it and did the method below but still the remote does not work

The Remote DOES show a blue light when pressing buttons, when pairing the remote using the below steps the remote does flash 3 times indicating a successful pairing.

But after everything looks like it should work it does not. I even messed with the remote setting on the front page. Anything else I need to do or a way I can force it to work? I currently have a working remote through CEC but want to have the other remote as a backup

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

Can you upload a log via My OSMC?

Just uploaded them to

Thanks. Your log doesn’t show any dongle attached.

Can you show a photo of the dongle so we can check it’s correct?
Can you try the other USB port?

So I tried it in the other usb port and it still did not work, I tried a rebind and then shut down etc. When I pair it it looks like it works with the blue lights blinking 3 times after plugging the USB port back in after pressing home and ok for several seconds, but the remote never actually works after that.

here is a pic of the adapter in the vero 4k, it did work at one point but stopped working about a year ago and I did not bother until now to try and get it working again since I’m using CEC, but if CEC stopped working I’d be SOL

So looks like the dongle may be bad then if both USB ports don’t work with this and the vero does not detect the dongle is in place?

Either that or my USB ports are broke.

What can be done to fix this?

Try a USB thumb drive on the Vero and see if it’s detected to rule out a USB issue (unlikely).

You could also try the remote on a PC, using the up or down keys to try and scroll a web page, or checking if it’s detected under Device Manager.

Can I just buy a new dongle and remote to try out? Not having any luck figuring out what is wrong with the current remote and dongle

Remote and dongle (included) are sold on the OSMC site.

But my recommendation would be to try in another device like a PC.