Can't reach MediaCenter interface after Upgrade

Is there something else I can do to troubleshoot the situation? I’m running a dist-upgrade every day, hoping something get fixed but I’m losing hope. What can I do to figure out exactly what’s broken? Any hint?

There was a suggested solution you could make to config-user.txt to boot without HDMI. Did you try this?

Sam

no, please can you link?

Already tried, nothing changed :frowning:

Yeah, I assumed that Sam had read your first post. I see that you already tried the fix described by fzinken.

AFAICT, this is indeed a weaknes of the hack/workaround, which works for boxes that are truly headless – and therefore don’t need a working display.

Take a look at this post: FYI...How I Fixed My Own Post v19.1 Problem and see if it helps.

Not sure how to apply this, I don’t have a HDMI display available.

Perhaps @grahamh can provide a random EDID file.

I’m not following… a random EDID file would work?

BTW this what tvservice replies:

root@osmc:/home/osmc# tvservice -s
state 0x80001 [PAL 4:3], 720x576 @ 50.00Hz, interlaced

root@osmc:/home/osmc# tvservice -l
0 attached device(s), display ID’s are :

root@osmc:/home/osmc# tvservice -d /boot/edid.dat
Nothing written!

Well, point 5 says:

If so, run “sudo tvservice -d /boot/edid.dat” to create an EDID file from your TV

My understanding is that it then runs off the EDID file. Caveat: I’ve not tried it.

He says -s to see if detecting TV then -d to save infos to file but -d results in a “Nothing written!”

You wrote:

and

You have zero attached devices.

So the idea is to connect once a HDMI display, have tvservice -d write its data to file (no matter what data) then use these as dummy values to somehow fool the RPi?

That is my understanding, based on reading the post from @WackyT I haven’t had a chance to try it yet.

I spent an hour last night trying all combinations of recommended fixes (cmdline and config) to get composite video to work. At one stage I had the OSMC splash screen but kodi stopped at that. After that I failed and couldn’t even reproduce that. So frustrating that the terminal hangs on the PC attempting to connect via ssh.

The answer must surely be in RPi forums somewhere.

OK, borrowed an HDMI display and made that dummy EDID file + added an entry in config.txt. Nothing changes.

grab-logs -z shows everything as disabled except the CV out: https://paste.osmc.tv/uqapokidid is that normal?

I spent a week… I won’t upgrade ever again.

Accordingly to this github post: drm/vc4: Initialization hangs when HDMI display is *not* connected · Issue #4457 · raspberrypi/linux · GitHub the fix is available in latest kernel. rpi-update is not available on OSMC so what should I do now, run dist-upgrade?

Thanks

OSMC runs it’s own Kernels. So you would need to wait till that fix is implemented in the OSMC Kernel and then published (most likely first in the development repository)

Hi

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv buster-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.