Can't reach MediaCenter interface after Upgrade


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb buster-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thanks, I’ll be glad to help. At this point I can’t run apt-get update against as it results in a 502 but I’ll try again later.

root@osmc:/home/osmc# apt-get update
Hit:1 buster/updates InRelease
Hit:2 buster InRelease
Hit:3 buster-updates InRelease
Err:4 buster InRelease
  502  Bad Gateway [IP: 80]
Err:5 buster-devel InRelease
  502  Bad Gateway [IP: 80]
Reading package lists... Done
W: Failed to fetch  502  Bad Gateway [IP: 80]
W: Failed to fetch  502  Bad Gateway [IP: 80]
W: Some index files failed to download. They have been ignored, or old ones used instead.

I’m not seeing that here. Please try again.

OK, upgrade worked. It now goes past splash, into login screen. Mediacenter still respond as “ACTIVE” but doesn’t show.


Try restoring your config.txt to how it was before modifying it.

I tried, same results.

Try to uninstall X11 and all it’s packages

Thanks, still no changes.

Did you find something on the logs which suggested this could be the solution?

Unfortunately, installing X11 has a tendency to break things on OSMC.

On your log I counted around 60 libx packages that probably needed to be deleted, along with x11* stuff. Just make sure you don’t delete these four, which are nothing to do with X11.:

osmc@osmc:~$ dpkg -l libx\*|grep ^ii
ii  libxkbcommon0:armhf 0.8.2-1               armhf        library interface to the XKB compiler - shared library
ii  libxml2:armhf       2.9.4+dfsg1-7+deb10u2 armhf        GNOME XML library
ii  libxslt1.1:armhf    1.1.32-2.2~deb10u1    armhf        XSLT 1.0 processing library - runtime library
ii  libxtables12:armhf  1.8.2-4               armhf        netfilter xtables library
1 Like

I see, so there’s no direct evidence of why mediacenter doesn’t show its interface, despite the service being running.

My suggestion at this point would be to first try with the latest image on a second SD Card to see if you can get your display working than can rework that into your current system.

I followed your suggestion + upgraded to the new kernel but still nothing changed. So frustrating :frowning:

Did you just try to upgrade or you tried a clean install with the new kernel on a second SD Card?

clean install on same card with new image

That only gives a new installer - you still need to update the kernel until there is a new update.

I did update the kernel following these steps:

  • Add the following line: deb buster-devel main
  • Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot

and after that I could go past the logo screen but after still no interface.

After about one month without being able to use the mediacenter and after dozens of trials and tests my solution to was to clean install previous version and disable upgrades.

Eager to continue testing this for others who need CV.

Hello, I wonder if CV output is now restored?