Can't reach my SMB shares after the last OSMC update!

This topic indeed has been produced, but the solution does not work for me.
My remarks are below. I do not use any passwords, so this does not work for me. Furthermore, the message I get is “not able to connect to the network server”. Before this everything really worked fine.

The issue you are currently experiencing with OSMC
I’m unable to access my SMB shares
What you were doing when this issue occurred
I had just rebooted after getting the latest update and tried to access an existing share.
Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.
I can reproduce it by trying to access an existing share again.This does not work.
The device you are currently running OSMC on
Raspberry Pi model 3
What peripherals are attached to the device?
None at the moment.
Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?
Yes, it’s happened right after the latest update. Before that, everything was working fine.

1 Like

Same here. Watching stuff - new updates - download and reboot. Shares all ask for username and password now, even though I do not use U/P for my network shares.

I guess this is to do with the Samba security update, but now it’s so secure I can’t access my non-password protected shares!

Help! I really don’t want to set usernames and password for the shares, as OSMC is not the only media player accessing them!

Are you using Windows? I posted a workaround here:

Since Win8 Windows also keep asking about password even if there wasn’t any, but we could bypass it using guest account (without joining to homegroup). Yesterday I wasn’t be able to use guest login on Kodi. Maybe empty pass field is unsupported, just guessing.

I saw that. But I’d prefer not to set a U/P for my shares, as other devices accessing those shares will also need to be ‘fixed’.

You may be right though - maybe guest access is now unsupported?

That would be a shame though…

BTW - using Windows 7 here.

You can do both.
Just add another account with password here (don’t delete Everyone/guest):

I don’t test it, but maybe you will have luck.

Ugh. I have the same problem.

Here are some debug logs

And a photo of the error message


I have the same problem since this morning not to connect to a Samba share.
When I make a connection request with smbclient here is the error message I get.

Server does not support EXTENDED_SECURITY but 'client use spnego = yes and ‘cli ent ntlmv2 auth = yes’
o The following constraints are applied to SMB1 connections:

  • “client lanman auth = yes” is now consistently
    required for authenticated connections using the
    SMB1 LANMAN2 dialect.
  • “client ntlmv2 auth = yes” and “client use spnego = yes”
    (both the default values), require extended security (SPNEGO)
    support from the server. That means NTLMv2 is only used within

Seems like as part of the security fix for SMB1 additional security features are enabled.
Which server are you using?

Also did you installed the updates on your server to patch the badlock bug?

it is a small rack nas on which I connect very well avat the updated this morning.
and the version of Samba that uses I have no idea

the osmc message : connection not permitted

Thank you for answering me

I guess you will need to update the samba server on the NAS as the badlock bug impacted the communication between the client and the server and as written above with the new security patch also additional security settings have been enabled on old protocols

the manufacturer no longer supports this and therefore no update possible.
But the trouble is that I tried on a windows share no login and no password.
And the problem is always the same

Help me

I found a parade.
I added the shares in the file show how ftsab on this site:

And I add an automount on boot

And it works

Same problem here. I’m getting a window titled ‘lock preferences for smb’ and then i have to enter password and username. On other devices i can access my shared files without any problems… Any solutions?

Same for me, cannot access my smb-shares…

— EDIT -----
I deleted the guest-access on my smb-shares and now it’s working again.

thanks chrissas ! it made the trick.

thanks @chrissas and @fzinken for the clues.

I was able to resolve the issue by adding ‘client NTLMv2 auth = no’ line into global section in .smb/smb.conf inside osmc home directory.

        client NTLMv2 auth = no

Now the problem seems to be resolved.

Note: Adding the setting to /etc/samba/smb.conf changes behaviour of smbclient itself however does not affect KODI and vice versa.


You added this on client or server?

I already tried this suggestion with @fzinken and he reported no success .

What kind of device are you connecting to?

Hi @sam_nazarko

Sorry I should have been more specific. The option has been added to the client (osmc on rpi#3). Server is Time Capsule.

hi baracudaz,

I tried your WA and it not worked /etc/samba/smb.conf

client NTLMv2 auth = no

I have my nas mounted in Asus router.

I made the test with new installation (april) and SAMBA worked fine,but after apt-get upgrade stop working.

any way to go back for samba files?