Cant save tvheadend recordings to NAS directory

I have a raspberry pi 3b+ with osmc and tvheadend installed, i access tvheadend via http from my windows pc and i have a qnap nas. The raspberry, pc and nas are all in the same network. I managed to mount a NAS directory to /media/recordings. I wrote it into /etc/fstab and also used mount -a. When I put a sample file into /media/recordings I could find it also on the NAS directory. I also changed the recordings directory to /media/recordings (While being loggin in over http as osmc, I cant log in as root, this might be a problem, but cant do it). However, when I want to record smth it never worked. When recording smth, tvheadend always gives the error message:

2018-05-28 10:47:21.486 dvr: entry 5ffbf167b1bb333b46d79f02d00d07c7 “Mysterien im Museum” on “kabel eins Doku” starting at 2018-05-28 10:13:35, scheduled for recording by “osmc”
2018-05-28 10:47:21.487 dvr: “Mysterien im Museum” on “kabel eins Doku” recorder starting
2018-05-28 10:47:21.488 dvr: About to set stop timer for “Mysterien im Museum” on “kabel eins Doku” at start 1527495245 and original stop 1527498104 and overall stop at 1527498104
2018-05-28 10:47:21.488 mpegts: 434MHz in Wartburg DVB-C Netzwerk - tuning on Silicon Labs Si2168 #0 : DVB-C #0
2018-05-28 10:47:21.489 subscription: 0035: “DVR: Mysterien im Museum” subscribing on channel “kabel eins Doku”, weight: 300, adapter: “Silicon Labs Si2168 #0 : DVB-C #0”, network: “Wartburg DVB-C Netzwerk”, mux: “434MHz”, provider: “ProSiebenSat.1”, service: “kabel eins Doku”, profile=“matroska”
2018-05-28 10:47:21.539 linuxdvb: Unable to provide BER value.
2018-05-28 10:47:21.539 linuxdvb: Unhandled ERROR_BLOCK_COUNT scale: 0
2018-05-28 10:47:21.539 linuxdvb: Unable to provide UNC value.
2018-05-28 10:47:22.062 mkv: (null): Unable to create file, open failed – Permission denied
2018-05-28 10:47:22.062 dvr: Recording error: “/mnt/recordings/Mysterien im Museum.mkv”: Unable to open file
2018-05-28 10:47:22.062 subscription: 0035: “DVR: Mysterien im Museum” unsubscribing from “kabel eins Doku”
2018-05-28 10:47:22.064 dvr: unable to stat file ‘/mnt/recordings/Mysterien im Museum.mkv’
2018-05-28 10:47:22.065 dvr: “Mysterien im Museum” on “kabel eins Doku”: End of program: File not created
2018-05-28 10:47:24.433 settings: Unable to create dir “/home/osmc/.hts”: Permission denied
2018-05-28 10:47:27.642 settings: Unable to create dir “/home/osmc/.hts”: Permission denied

This seems strange. Why would it be trying to create that directory - it should already exist. Does it? And does it have the right permissions? Should be:

osmc@vero4tv:~$ ls -al .hts
total 12
drwxr-xr-x  3 osmc video 4096 Jan  1  2015 .
drwxr-xr-x 13 osmc osmc  4096 May 24 15:02 ..
drwxr-xr-x 14 osmc video 4096 May 26 12:27 tvheadend

So it’s not trying to write to /media/recordings. Personally, I mount the drives I use all the time under /mnt/ and leave /media/ to deal with USB drives that might get plugged/uplugged.

Sorry, the log file was from a different setup. I keep changing all the time to make it work. In the log file it was /mnt/recordings. However, doesnt work either.

No, the /home/osmc/.hts directory DOESNT exist. Now that you say it, I remember that while I installed the TVheadend server on the backend, I got an error message, that the TVheadend server is not ready or smth similar. But it seems that after a while the tvheadend server worked, so I thought this was fine.

Ok, can you tell me which directories to use and which command to write into /etc/fstab ?

And what should I do about the missing folder ?

How did you install tvheadend? From the MyOSMC app store?

Please confirm that you are running TVH on the Pi that’s running OSMC. If not, we need more information about your setup.

If you are running TVH on te OSMC device and you installed TVH from anywhere but the OSMC AppStore then please uninstall it and follow the instructions here: [Obsolete] Instructions for Viewing Live TV - #56 by b3n_ja_m1n

I downloaded the OSMC installer (for windows and raspi) to my sd card, installed it on the sd card. Put it into the raspi (which is connected to the network), connected mouse, keyboard and monitor to the raspi and installed the tvheadend server in this menu. I think the menu point is called Myapps. When i clicked on the TVheadend server I got the error message which I mentioned above.

I checked the users, there is no user called hts !!! I have users root, …, ntp, statd, sshd, osmc and ftp. But no hts.

No, there won’t be. It doesn’t work like in other linux distros.

Ok, what to do ?

I’m struggling to understand what you posted above. But it seems you have installed OSMC without issues, then used the MyOSMC AppStore (the shoppoing cart icon under MyOSMC) and installed tvheadend without issues.

Am I right so far?

@volker.ludsteck Hi Volker, you mentioned two different directories:

  • /media/recordingsyou configured and tested using the /etc/fstab method
  • /mnt/recordings which Tvheadend uses

Could you recheck at http://<DNS/ip of your Tvheadend system>:9981 what you have configured at Configuration -> Recording -> Digital Video Recorder Profiles -> <your used profile> -> Recording system path ?

I can see why you are asking this. But as I told you before, I can record to the raspi device, i.e. /home/osmc, however the problem is when I try to record to the NAS.

But the answer is: the recording system path is: /mnt/recordings

Well, I wrote 2 times that there was some error message when I installed the tvheadend addon. However, it worked lateron and I even can record. So, the problem only arose when i tried to record to the nas.

So, Tvheadend is running on the Pi, the NAS is mounted to /media/recordings on the Pi … if you want Tvheadend to record something to the NAS, why you don’t configure /media/recordingsin Tvheadend?

I tried both, and even more. I mount the NAS directory to different raspi directories and whenever i did this i changed the recordings directory in tvheadend. In no case it worked !!! And whenever I changed the mount I changed the /etc/fstab. As there are many different versions of the gics command, maybe you could indicate one that is working good.

No, you said there was an error message when you tried to record something, not when you installed tvh or the addon. Then you described how you installed OSMC which I couldn’t see was relevant if it went OK. Sorry if i’m being slow, here.

I wrote this !!!

and this:

“When i clicked on the TVheadend server I got the error message which I mentioned above”

2 times, as I said !!!

Hence the question: is the backend the same device as the one you have installed the tvh addon?

Then I was coming to what you mean by clicked on the TVheadend server. In MyOSMC? In a web browser?

Some of the config changes to Tvheadend are getting activate only after Tvheadend restarts.

I suggest

  • to configure Tvheadend to /media/recordings

  • on the Pi check the permissions of /mediaand /media/recordings; user osmc needs read and write permissions to this

  • restart Tvheadend like sudo systemctl restart tvheadendon the Pi or simply reboot the Raspberry