Can't see USB storage [SOLVED]

Hello, I’m new to the forum so far enjoying OSMC coming from OpenElec.

One problem though. I have a repository zip on a USB stick but I can’t seem to get it working in OSMC. It was working fine in OpenElec just before I installed OSMC.

Just wondering if there is anything I can do that doesn’t result in needed OpenElec again.



How is your RPi powered? Are you using a good PSU?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Should be automounted under /media/LABEL, where LABEL is the label-name of your USB-drive.

Thanks. Nothing under /media. I also added the line ‘max_usb_current=1’ in config.sys as per another thread which hasn’t made a difference.

I have the best power supply available. Seems strange that it was working only an hour ago in OElec.

Hope this log help. I prefer OSMC

That’s not a debug log unfortunately.
And setting max_usb_current is not needed anymore with RPi3.

I just followed the instructions from the link you provided me. What is it I am missing?


That part:

Before uploading any logs, you should ensure that Debugging is enabled in Kodi.

(or my mistake - if so, than sorry.)
Yep, pretty sure - my mistake. Sorry again.

I think you sent us an email today and remarked that you find problems with the drive unmounting itself randomly.

Please make sure you’re using a good power supply.

Great thanks. I hit the debug tab before logging. That’s wasn’t me about unmounting, I only joined an hour ago.

Okay – same thing still applies: check PSU.
How is the disk formatted?

Your stick is physically not detected.
Can you still read the stick when you plug it into your PC?
What Brand and Size is the stick?

I solved it. I installed OSMC onto a micro-sd card inserted into a USB adapter in windows but I chose USB via the OSMC installer instead of SD. I presume this screws up the installation somewhat. What would be the technicalities of this?, I would be interested if someone could enlighten me, here to learn.

Thanks for all the help guys.

Ok, that explains what I saw from your log file.
So actually you installed the boot files onto the SD Card and then have choosen to install OSMC onto the USB Stick. Which means the content of the USB Stick was overwritten by the Installer with OSMC OS files. Which means the USB stick was physically connected but you might just have not seen anymore the files you expected.