Can't SSH from Windows (only from iOS)

I have a RPi 2 running OSMC and access from iOS (FTPManager Pro app and Terminus app) with no problem. But I can’t access from Windows 10 using FileZilla (error: Server’s host key did not match the signature supplied) and Putty (error: Server’s host key did not match the signature supplied). Any idea?

your host key has changed. you formerly logged in. Try to find the line in your known_hosts file or delete it completely and log in again and verify the host.

I have to do that on OSMC or Windows machine?

On the Windows machine.

Apparently PuTTY and FileZilla store their known host keys in the same place;

I have nothing like that here…

better do this if not comfortable with regedit:

open command prompt
“c:\Program Files (x86)\PuTTY\putty” -cleanup

same error:

if your pi/osmc ip address is
what happens in the command prompt if you enter

“c:\program files (x86)\PuTTY\putty” -ssh osmc@

Happens same error…

did you install putty under another user account? that would explain why you could not find the sshhostkeys registry entry in your context…

I see that gandalfhh corrected this cleanup command but you seem to have run the original (incorrect) version:

Maybe try again.

I install with my user (I dont have any other user on my pc)

tried again but same s@$% error :sweat:

Two things:

  1. Let’s figure out if a key mismatch is actually what is happening. So did you recently reinstall your Rasperry Pi?
  2. I suggest to go back to your registry and just start a search for the Key “SshHostKeys” it must be somewhere in there

My installation is not new (and I can access from iOS apps). I searched all regedit and have nothing with SshHostKeys

That sounds like more a failure on your Windows machine. Try to deinstall filezilla and putty and then only first install putty and try to access again.

reinstall putty and get same error (I didnt intall fillezila this time)

I just installed Putty on a Win7 machine and after one SSH session, I can see the host key in HKEY_CURRENT_USER\SoftWare\SimonTatham\PuTTY\SshHostKeys

Please check once again to see if anything is there. It might be a Win10 issue but I don’t have it installed on any of my machines.

I have the same reg entry on Win10: rsa2@22:osmc.

rsa2 is a bit strange. My host key algorithm is showing as ssh-ed25519 in the registry.

Since mine is a brand new installation of Putty, it could be that there is some old configuration from the previous installation still in your system.

When you run Putty, before you connect, see if there is a saved Session for the OSMC box. If there is something, either for “osmc” or its IP address, please delete it.