Can't SSH or ping but can connect to internet


I set up my Pi 2 with OSMC RC2 (usb install) a couple of days ago. Initially everything seemed fine, the android remote app (Yatse) all worked, playing youtube videos etc all working very well.

A couple of times, the Pi starts and the Yatse app cant connect, i cant SSH, or ping the box but the Pi can still check for addon updates and access youtube!!??

However, if i go into My OSMC > network > and turn off and on the wireless adapter it works again!!

My only thoughts are

  • the router playing up (BT hub 4), but i see no settings for anything that would suggest network traffic is being lost or disabled though, the same ip address always gets assigned.
  • there’s currently 4 devices plugged into the Pi (2 amp power supply): a wifi dongle, a keyboard (very cheap and basic), a usb stick (where its installed), an a self powered usb drive for media and maybe a power issue? but i dont understand why this would cause this problem.

Things I’ve done beyond a basic install

  • install transmission-daemon
  • install youtube addon
  • install samba (done last and issue was occuring before this)

Any help would be appreciated!

What model of wireless adaptor are you using ?

I have seen similar behaviour with my Edimax EW-7811UTC (which uses the rtl8812au driver) - I’m connected to the wireless network and can connect to the internet fine - I can check for updates, and I can even stream a 10Mbps movie trailer using the Apple iTunes Trailer addon, however I cannot connect to my local SMB sever on a Mac - even by IP address, it just times out.

It doesn’t do it all the time either. If I swap it for one of my other wireless adaptors the connection to the SMB server works perfectly all the time. So far I have been unable to find the cause for this, because in theory a wireless adaptor or driver shouldn’t be able to cause this kind of selective problem…

Thanks for the reply.

Yeah, I’m using this one:

So, maybe is the wireless adapter… The odd thing is that my friend has a Pi (B+) with this same model running raspbian with samba / minidlna running and its always been fine. Everything else is different though (power supply etc.).

Its not a major problem, just really annoying when you want to watch a movie late at night and you cant use the remote control (my phone :smile: )

As strange as the symptoms seem I suspect its a bug in the driver for the wireless adaptor - the rtl8812au driver is an “out of tree” driver (it doesn’t come with the standard linux kernel) and there is more than one version of this 3rd party driver floating around, so assuming it is the driver there may be some room for improvement there.

Wonder if i compare the drivers between mine and my friends setup if that will help.

This blog post
mentions a power saving feature of the WiFi adapter, in this case Ralink Technology, Corp. RT5370 Wireless Adapter.

That said my Pi2 with this adapter can boot to Raspbian or OSMC.
With Raspbian all is well with ping or ssh from another machine on wlan0 (without the fix in the post).
With OSMC it works for a few moments and then I can’t ping / ssh.

Do you definitely have the latest updates installed, in particular the kernel ? If you run

cat /proc/version

You should see:

osmc@rpi2:~$ cat /proc/version
Linux version 3.18.10-1-osmc (root@vero) (gcc version 4.9.2 (Debian 4.9.2-10) ) #1 SMP PREEMPT Mon Apr 6 15:34:17 UTC 2015

I have an adaptor using the Ralink RT5370 chipset (a Tenda 311M) and have not noticed any problems with it. In fact whilst it is the slowest of my adaptors it has always maintained a very reliable connection.

If you can try to reproduce the problem where it drops out, then temporarily connect via Ethernet and use the log uploader to upload your logs that would be helpful.

Also how far is it from the base station and how many green dots do you get for signal strength in networking settings ?

My /proc/version is the same.

As it turns out, I did the wireless setup again and now I can’t reproduce the problem (I gave a static IP; I probably got it wrong the first time around).