Cant start OSMC after power cut on RPi 2 [solved]

Sometime in August this year there was a local power cut, not sure if this has corrupted my SD Card. Today after rebooting I was left with the message on TV screen:

FATAL ERROR: Could not find root filesystem on /dev//mmcflk0p2

This dropped me to an initramfs.

Confirmed that I had two partitions on my SDcaed mmcblk0p1 and mmcblk0p2. I have an
external hard drive mounted via a USB to SATA adapter and looks like system was trying to boot from wrong drive.

A cold boot (power off and on) fixed this and OSMC powered up properly using August 2018 build. I did a manual update to December 2018 (using OSMC screen manual update)
but now am left with a black screen and alternate blue sad face,

I still have SSH access and
I have moved ~/.kodi to ~/.kodiold

Starting from console I get:

osmc@osmc:~$ sudo /usr/bin/mediacenter
Starting Kodi…
/usr/bin/mediacenter: line 142: 18846 Illegal instruction sudo -u osmc $KODI --standalone -fs --lircdev /var/run/lirc/lircd
Kodi exited with return code 132 after 0 hours, 0 minutes and 1 seconds

Looks like lircd is corrupted .

I have uploaded grab-logs -A link below/:

I can take SDcard out of RPi 2 and check in another linux machine

Is it possible to reinstall using command on this link:

Thank in advance for any help with this, looks like a reinstall ?

It’s not lircd that’s the problem, it’s kodi.bin.

You might as well try to reinstall the mediacenter package. If it still fails, then a full reinstall of OSMC might be the best way forward.

From the command line:

sudo apt-get update
sudo apt-get install --reinstall rbp2-mediacenter-osmc

Hi dillthedog,

Many thanks for a fast reply, and the result back with a working system !!
Did not thing there was a way out of this one
Will mark first post as solved now