Can't update (RPI2)

I’ve been running OSMC on this Pi since Alpha 4. I will admit that I was one of the first to use mcobit’s RetroPie script.

Today, I saw that there were some updates to the skin and an RC3 was out. I don’t remember if I was running RC1 or RC2.

I had some problems updating so I decided to do a clean install with RC3 since I attributed the problem to the RetroPie stuff. I’m still having problems updating. The first time the updater stalled at 77% (I left it there for at least an hour and a half). I wound up rebooting and now it says at 18%. Both times it was “Preparing mediacenter-addon-osmc (armhf)”

I am using an NFS install and here is the output of dmesg when the hang occurs:

[  845.575382] nfs: server XXX.XXX.XXX.XXX not responding, still trying
[  960.816101] INFO: task dpkg:611 blocked for more than 120 seconds.
[  960.816128]       Tainted: G         C     3.18.13-1-osmc #1
[  960.816138] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[  960.816151] dpkg            D 806a6a00     0   611    590 0x00000000
[  960.816217] [<806a6a00>] (__schedule) from [<806a7374>] (io_schedule+0xd0/0x178)
[  960.816244] [<806a7374>] (io_schedule) from [<806a7ac0>] (bit_wait_io+0x44/0x6c)
[  960.816270] [<806a7ac0>] (bit_wait_io) from [<806a7e58>] (__wait_on_bit+0x12c/0x178)
[  960.816296] [<806a7e58>] (__wait_on_bit) from [<8014064c>] (filemap_fdatawait_range+0x1d8/0x234)
[  960.816322] [<8014064c>] (filemap_fdatawait_range) from [<8014070c>] (filemap_fdatawait+0x64/0x70)
[  960.816348] [<8014070c>] (filemap_fdatawait) from [<801ea08c>] (__writeback_single_inode+0x210/0x330)
[  960.816393] [<801ea08c>] (__writeback_single_inode) from [<801eb0e4>] (sync_inode+0x16c/0x210)
[  960.816419] [<801eb0e4>] (sync_inode) from [<802e00c4>] (nfs_wb_all+0x5c/0x16c)
[  960.816445] [<802e00c4>] (nfs_wb_all) from [<802d3e28>] (nfs_setattr+0x330/0x338)
[  960.816471] [<802d3e28>] (nfs_setattr) from [<801d7cbc>] (notify_change+0x16c/0x334)
[  960.816502] [<801d7cbc>] (notify_change) from [<801ac0f4>] (chown_common.isra.14+0x88/0x10c)
[  960.816528] [<801ac0f4>] (chown_common.isra.14) from [<801ae0a0>] (SyS_fchown+0x64/0x7c)
[  960.816555] [<801ae0a0>] (SyS_fchown) from [<80015dc0>] (ret_fast_syscall+0x0/0x48)

I don’t understand why it says that the NFS server is not responding as I can ssh to the Pi and access the filesystem that’s mounted from the NFS server.

Any ideas?

Can you check the apt.log? Did ‘connman-osmc’ get updated? I suspect that may be the issue, although it shouldn’t be touching eth0.


Where is the apt.log?

I checked /var/log/apt/history.log and /var/log/dpkg.log and grepped for conn and both returned nothing.

Not sure if it’s related at all, but if I issue a “sudo reboot” from ssh, I get to “[ OK ] Reached target Shutdown” on the TV and it never actually reboots.

Now I remember having to make changes to cmdline.txt when I did my initial install of RC1. Let me see if I can find that thread… :slight_smile:

There do not seem to be many NFS users of OSMC, perhaps because the benefits of doing so have been negated over time.

I’ll keep an eye on this thread, keen to get to the bottom of it.

Can you describe your NFS setup: is it static or DHCP? Can you repicate not being able to shut down properly on a fresh RC3 install?


I went through a few SD cards when I was running Raspbmc (I actually wound up NFS mounting /home/xbmc so that when I had to reload the Pi, I wouldn’t lose all my settings and have to completely reconfigure it), so I decided to use NFS with OSMC since it was available. I also like that I can just shutdown the Pi and make a copy of the data stored on my QNAP to test new versions and the like instead of using a bunch of SD cards with clean installs. For example, I just made a copy of the folder on the QNAP (which had OSMC install with RetroPie) before I started to upgrade in case it went south.

My setup is using DHCP, but I have a reservation in my router so it’s always the same IP (not sure it matters).

Looks like this thread ([RC} NFS Install Issue Resolved) may be the solution again. I added the “,vers=3,tcp” immediately after the NFS path and I’m up to 37% of the update and I think it already passed the “mediacenter-addon-osmc (armhf)” package.

Yup, that did the trick. The update finished and I have the new skin! :heart_eyes:

Interesting. I have got a fallback in the installer where NFSv3 is chosen if NFSv4 is problematic. It is odd NFSv4 has only started causing you issues now and this may not necessarily be your issue. Did you recently get an update for your NAS that may have changed default behaviour for NFS?


I have gotten a few updates on the QNAP in the last couple of months (but I don’t recall anything about NFS in the release notes). But the odd thing is that before the fresh install of RC3, my last install had those options in cmdline.txt. Although I suppose that it’s still possible that the RetroPie scripts could have still been the reason why I couldn’t update in the first place.

With the fresh RC3 install, OSMC would boot and I could see the movies on the QNAP and play them without updating cmdline.txt (where it wouldn’t with RC1), I just couldn’t update the “mediacenter-addon-osmc (armhf)” package.

If nothing else, hopefully this helps the next NFS user. :smile:

oh and I dig the new skin BTW! Great Job!