[RC} NFS Install Issue Resolved

I just completed an NFS install of the RC and encountered a problem.

There is a small chance that the write to the SD card was done with an older version of the installer. So make sure you are using the latest version, just in case.

The issue I had was that the install went fine, but the file system wouldnt mount on the reboot after install.

I discovered the reason was a couple of errors in the cmdline.txt file which I found when I put the SD card back into my laptop.

This how it looked originally:

root=/dev/nfs nfsroot= ip=dhcp:: rootwait quietosmcdev=rbp1

This is the version that finally worked:

root=/dev/nfs nfsroot=,vers=3,tcp ip=dhcp rootwait quiet osmcdev=rbp1

Note, the :: was removed, the space was added between quiet and osmcdev and ,vers=3,tcp was added after the OSMC path.

Hope this helps somebody.

P.S. as of writing, networking settings is not working for NFS installs.

Interesting, I had the same problem last night with a Pi2 and this morning confirmed with a Pi1. My cmdline.txt does look like your first one. Let me go re-download the installer and give it another shot.

I downloaded the installer from Download - OSMC and still the cmdline.txt looks like the first one you listed and it wouldn’t boot after the install. I was able to update the cmdline.txt manually to look like the second one you listed and it booted.

This is on a Pi1. I’ll try the Pi2 later today.

Fixing cmdline.txt per above seems to make the NFS mount work on my Pi2, but OSMC seems to immediately go into a “sad face” loop. I see 2-3 red messages scroll by, but too fast to read.

During the sad face loop, SSH doesn’t work:

[xxx@xxx:~] 1 $ ssh osmc@osmc
OSMC: Open Source Media Center
osmc@'s password: 

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun Mar 15 16:28:47 2015 from 2001:a60:1515:c201:211:32ff:fe22:186f
Could not chdir to home directory /home/osmc: Permission denied
/bin/bash: Permission denied
Shared connection to closed.

Any ideas?

Found it. My NFS root was
drwxrwxrwx 22 root root 4096 2015-03-15 17:12 osmc
when it should have been
dr-xr-xr-x 22 root root 4096 2015-02-05 17:14 osmc

I have the same problem wit my NFS install.
How did you change the permissions from drwxrwxrwx to dr-xr-xr-x (i’m using a synology nas )

i changed it with chmod 555 /path to osmc But i still get that sad face screen. How can i find a log file. i can’t ssh

Same problem here. I was running Alpha4 before via NFS install without problems.
But latest RC version won’t work. The installation seems fine but after reboot it just gets stuck in a sad face loop during boot.

Changing permissions didn’t help for me. Tried different lines in cmdline.txt. No luck.
My NAS is a Synology.

Any ideas?