Can't write to external HDD?


I’ve been using OSMC on my Raspberry Pi 2 for a couple of days and I’m loving it. The only issue I’m having is that I cannot transfer files to my external HDD from Windows using Samba. (Formatted as ext4)

I can locate it with Samba (under devices) and read all the content but I cannot transfer files to it. When trying with Samba it says that there is insufficient disk space (which is untrue because there is 1+ TB free)

I think for some reason that it is reading the free space of the SD card and not the external HDD. Is it possible to fix this somehow?

I’ve tried to locate the content via FTP but that does work either. (Gives me a simple transfer failed error)

What could be the issue? I think I probably needs to change something with Putty but I have no idea what.

Kind regards,


try transferring a very small file via samba to the disc see if it works - there is an issue regarding where the drive is mounted - this will find oiut if its that issue

from @DBMandrake on another thread

This solves a number of issues including incorrect reported free space that can cause copying issues. Anyone who already has Samba installed will still have a devices share after upgrading (so we don’t break any reliance you might have on that share existing) but new installs of Samba will not get a devices share.

Hi Galaxynik,

Thanks a lot for your reply.

I can succesfully transfer files via Samba, but for files above 3 GB it says that there is insufficient diskspace.

3 GB is similar to the space that is available on the SD card, so that is why I’m thinking that it is somehow reading free space off the SD card and not the external HDD, because the HDD has loads of space availabe. (1+ TB)

If I try via FTP (/media/hddname/) it does not work at all and comes up with this error:

Response:	553 Could not create file.
Error:	Critical file transfer error

I’ve checked in the /mnt folder and the HDD does not appear in there. Shouldn’t it do that?

Kind regards,


PS. It should also be noted that I have not done anything manually to activate the HDD. I’ve plugged it in via USB and it appeared in OSMC automatically. Should I do something to correctly mount it?

yes I think if you create a mount point one level down eg /mnt/mydisc/hddname and mount it there you should be able to copy larger files to it, I think that there is an update on the way (may already be here) to cope with this (are you up to date)


I’ll try to run an update!

If it doesn’t work, how do I create a mount point? I am completely lost when it comes to linux and command prompts. :slight_smile:

Kind regards,


Edit: So I managed to mount it via a help Google link but the issue is still the same. Windows says that there are insufficient disk space in devices when trying to transfer files to devices/usb_hdd/ (my new mount)

What could be the issue?

1 Like

Absolutely brilliant! Thanks a lot, that was my problem exactly and the solution worked. :smile:

Have a great day.

Kind regards,


Hi again,

I thought I’d bump this thread instead of creating a new one since the problems are probably related.

The above solutions worked but I have two more issues:

I’ve mounted /dev/sda1 to /media/usb_hdd but if I restart my Raspberry Pi 2 it forgets the mount-point I’ve created and also deletes the mount-folder. So after every reboot I have to enter:

sudo mkdir /media/usb_hdd
sudo mount /dev/sda1 /media/usb_hdd

How can I make it remember this?

After my Raspberry Pi 2 had idled for some time (12 hours+) I cannot connect to it from Windows with Samba anymore. It says “Cannot access \OSMC”. I can connect through SSH with no issues and I’ve tried to view media files etc. on it to make sure it hasn’t crashed.

What can be the reason for this?

Kind regards!

The issues with incorrect free space reported on external drives over Samba, and inability to write to external drives through samba should be fixed with the most recent updates.

Anyone still having problems with this please let me know.

I just updated OSMC on my Pi2, but I’m still having problem writing external HDD attached to Pi2 via USB through FTP.

[R] 550 Could not get file size.
[R] 227 Entering Passive Mode (192,168,1,73,219,59).
[R] Opening data connection IP: PORT: 56123
[R] STOR IMG_20141013_160342195.jpg
[R] 553 Could not create file.
[R] Transfer Failed: IMG_20141013_160342195.jpg

Thanks in advance for your help.

I just enabled writing rights using the below instructions:

osmc@osmc:~$ sudo chown osmc /media/mnt
osmc@osmc:~$ sudo chmod 777 /media/mnt -R

Did you see this thread ?

No I didn’t. I was searching for an ftp thread not samba. However thank you for your guidance.