Capturing TV EDID data: issues with CEC [SOLVED]

Currently I’m on the final update of Raspbmc and very happy - all working beautifully.

I’m wanting to switch over to OSMC within the next week to get a feel for it. I’m not sure if it’s structured the same as Raspbmc.

With Raspbmc I’ve had to capture my Panasonic Viera V10A’s EDID file and add it to /boot and set hdmi_edid_file=1 in config.txt. I have an HDMI audio splitter which was causing issues with CEC.

Is the procedure for applying the EDID settings the same in OSMC as it was under Raspbmc?

Yes, as the Raspberry Pi is still the same, it will need the exact same settings under OSMC.
There shouldn’t be any difference in the config.txt-file from Raspbmc to OSMC.

Thank you very much.

Now having major issues.

After installing OSMC I turned off the TV - pulled from power completely to reset CEC.

I’ve noticed the config.txt already has hdmi_ignore_cec_init=1 as with Raspbmc.

Started the TV and then the Pi. All fires up nicely but there are two instances of the Pi. One as the Recorder and one as the Player. Selecting either of these options starts up and sends me to the Blu-ray player.

Whatever I do I am unable to get rid of the two instances of the Pi which really aren’t the Pi. Booting up the Pi first then the TV. Turning everything off and on again etc.

This does not occur with Raspbmc. Stopped everything and mounted my Raspbmc SD & USB and everything is back to normal as it should be.

I have used the EDID I captured under Raspbmc and just loaded that into /boot. I shouldn’t have to capture it again as it is unchanged.

Any ideas or pointers.

Ok, after plugging and unplugging and turning stuff on and off for several hours last night and again this morning it is finally working - shouldn’t be that hard.

Anyway. It seems to be working now.

EDIT: Have received my Rpi-2 and had no issues with CEC this time around. I think it’s the Panasonic TV playing funny buggers at times - even if you pull the power for some time.