Cast to osmc rpi

I am trying to cast from my android phone to OSMC on rpi3. The content is on a NAS that I reach by the NAS builders’ proprietary app, in this instance zCloud. The app finds the OSMC, but casting, which at one time worked with at least photos and music, rarely with video, and now, seemingly post-last update, not with any of the three ‘modalities’. Fault of OSMC, RPi or ZyXel? Or of user?! Anybody else successfully tried anything similar?

And which screen should I use? It used to be that the material turned up on the primary screen (the one before you choose what source you want to play from). Now nothing…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Some images of what you see vs what you expect to see may also help