CB2: IDE/SATA adapter - SATA HDD boots, SATA SSD does not


I want to replace the original IDE HDD with SATA SSD. In oder to accomplish this, I bought a IDE/SATA adapter.

Status quo:
I have made two clone drives of the original IDE HDD:
(1) SATA HDD - I hooked it up via the IDE/SATA adapter and even though there are some errors during startup the system boots OK.
(2) SATA SSD - I hooked it up via the IDE/SATA adapter and unfortunately there are several errors during boot so the system never boots. By the way, this SATA SSD boots fine via the ATV’s USB port thus there’s nothing wrong with the SSD.

Given the boot screen shots below, can someone please help me resolving the issue of SATA SSD not booting properly? As far as I know there are several people out there that have installed SATA SSD drives via an identical IDE/SATA adapter so they must have faced the same issue.

Thank you!

A. IDE HDD - boots OK

B. SATA HDD (via IDE/SATA adapter) - boots OK

C. SATA SSD (via IDE/SATA adapter) - does NOT boot OK

Hi Friend,
I have three ATV1s all installed with Msata SSD drives, on Ide/Sata adapters, and I never had a problem with booting up with CB2 , I have also used full sized Sata SSDs and never had a problem with them either, so have you a picture of the adapter you are using, there are a number of different ones out there.


Here is a picture of the adapter.

I am really looking forward to hearing from you!


This is the 5V mSATA/IDE Adapter I use successfully (with OpenELEC) with a 32GB ADATA mSATA SSD:

The mSATA screws to the top of the adapter.
I would just buy another one, as they are so cheap.

Heading ##Hello my friend, my worry is that if the ide/sata adapter worked with your sata hd it should have worked with the sata ssd drive, over the years I’ve used varies makes of SSD and only came across one that would not work on the ATV1, only problem now is I forget the brand name, the adapter that you are using has no link connector, I had purchased a couple of the same without the link connector and they never worked for me, I then purchased a couple with the link and bingo, they all worked, I have quite a few of these spare, and you are welcome to have one, if that fails, it is probably the ssd not compatable with the adapter or the ATV1, anyway my friend you are welcome to the adapter, there is no charge, only to willing to help you.

EDIT: The text below is irrelevant as this was written before the MondeoMan’s post.

To be on the safe side, I will repeat what is written in the post. My current adapter WORKS, but only with SATA HDD. The adapter does NOT work with SATA SSD. You can see the logs above. Does this really mean that I have to buy a IDE to mSATA adapter and in addition a new mSATA drive? Could it be that there is a simple thing I need to change in the code instead?


Had the same adapter, only mine the connectors sticking up from the pcb (meaning almost impossible to fit inside an atv) I vaguely remember I had to do a lowlevel format (or something similar) of the sata ssd (with the ssd connected to the ATV) before the ATV would recognize it properly. Im not sure of the precise circumstances, since it’s so long ago. Try using the openelec restore image. It’s probably your best chance.

Hi Mondeoman. Thanks for the explanation and the offer. I have sent you a private message.

Hi Mate,
where do I find my PMs, I’m new to this forum.

First click the big M at the top right corner and then click Messages.