CBC and Travel Channel Addons not working

I am using the latest updates for OSMC on my Raspberry PI and add ons are up to date. But some while back the CBC (canadian Broadcast Corp) started giving me fits (very intermittent), then with the latest round of updates the Travel Channel stopped completely. It says check the logs so i uploaded them. I will post the link here in hopes that someone with much more experience than me can tell me what the issue is. Here is the place it uploaded them to http://paste.osmc.io/regodicehu
I even tried rolling back the CBC add on. no help.
Thanks in advance for some help or enlightenment on whats going on

Not much we can do for you regarding those addons if they are installed via superrepo there is the issue of piracy.

Thanks for responding, I just checked and both CBC and the travel channel are installed from the offical Kodi.tv repository

The CBC makes most of it’s content available on the web since it’s a publicly funded broadcaster.
In fact, all the Canadian broadcasters make much of their content available online.

The log shows urls for “theplatform”, which is CBC’s server system.

On the other hand you have a bunch of pirate addons installed. navi-x etc
Some of them cause problems with kodi and legit addons.

I’d try removing or disabling the addons that are not from the main kodi repository, and then enabling the CBC addon and see what happens.

There is also a chance that the CBC addon hasn’t been updated to handle possible changes on the CBC servers. It’s always best to contact the addon developers for help with this type of thing.

If your system plays videos from other legit addons, and from your local media files, then it’s the CBC addon (or other addon) itself that’s got a problem.

The first stop in troubleshooting a problematic add-on is the official add-on thread on the Kodi forums. Until proven otherwise, OSMC should not have any effect on add-on function.

In addition to what ActionA said, each addon has a developer, and in many cases that developer has a forum where he/she/they can be contacted for support on their specific addon.

superrepo is known to break dependencies in kodi since their repo contains older versions but as actiona said seek support on kodi forums

Thank You all for the response,I will uninstall the superepo addons and go from there.

I’m running OSMC 2015.12-4 on the ATV1 hardware.

I just installed both the CBC (version 2.0.8) addon and the Travel Channel (version 1.0.4) addons from the official kodi repo.

I played some random video streams January 19/ 2016, with both addons, and they both worked fine for me.

Thanks Spinner, as an update for everyone , i took out all SuperRepo addons. And The Travel Channel Started working.
CBC is still not working, there is another addon that i can not get rid of , smokedpi. i have no idea what it is or what it does. it is listed as an video addon and a program, both say the cant be removed due to the other being installed.
I believe i am going to start over and not put anything else on but CBC and go from there, checking the logs if necessary.

seems like its adult related its an repo that comes from banned addons

1 Like

Ok everyone. I took out the SD card and loaded the latest OSMC . Let it configure and then added the CBC video add on. nothing else , no other repositories nothing. okay i did configure Yahoo weather.
Still strange behavior. it will let me watch some shows , yet others throw an error. shows that work are anything ( i think) under Absolutely Canadian. Shows that don’t work are The Nature Of things it throws an error into the log. the log is here
http://paste.osmc.io/ekemekarid. I also posted this to the Kodi forum under addon support. just wanted to give an update and thanks for your help. John

thanks @gourash !

I didn’t try one of the nature of things links. When I get a chance I’ll try one.

I’m wondering if CBC has changed their website recently, which would screw up the addon.

Thanks Spinner, i think all of this started for me around november, but there have been many updates since then.

Just played some “Nature of things” streams that were in your log.

Manufacturing the wild, ocean magic, puffin patrol and others worked.

“Sonic magic” failed with the HTTP 404 error, which meant the video file wasn’t found on the CBC servers. But, the video is on the CBC website.
Based on the name of the clip, I guessing that the add-on May have problems with videos that use special characters in the name ?

Give that video as a specific example to the developer, and see what he says…

Definitely a bug in the add-on.