CEC Adapter no more working after november update

Hi everybody,
after applying november update on my vero 4k+, CEC operations with my Samsung TV does not work anymore.
After OSMC restart a little window tell that the CEC adapter can not be initialized.

Log attached : Pastebin

Thanks for your help
Gigius

CEC hasn’t changed in this update.

Has something changed in your environment?

Has your TV received a firmware update?

Can you try power everything down at the mains for a few minutes?

Thanks!
All my devices are set to update manually, so no update were done.
Anyway, powering down at the mains all devices for some minutes was the perfect suggestion!
Thanks a lot!
Gianni

Hi everyone,

Strange … I’ve just had the same problem… I had TV (Samsung) and Vero4K+ disconnected for the weekend, while we were re-decorating the sitting room. When I plugged everything back in, I got that same ‘CEC error message’.

I’ll try powering down everything for a while … .as soon as the kids are off the Xbox :slight_smile:

Thanks

Did your TV get a firmware update perhaps?

Sam

CEC works fine with my Samsung Q9FN after the Oct update.

TV has no network connection, so I presume nothing has changed there. Cec not working with either Vero. Both before and after latest osmc update. I’ll try leaving TV unplugged overnight.

You only need to wait about 5 minutes normally. And if you have an AVR also unplug that.

thanks. After overnight plugged-out, TV is still the same.
The only difference is that the XBOX was used by the TV for a couple of days, and then when I connected the Vero 4K back to the TV, then I got the CEC error.

Did the XBOX somehow change my TV configuration? … that’s the only thing I can think of

Unlikely. You could try turning off CEC (Anynet+) in your TV’s menu, power cycle your TV, and then turn it back on. You could also try a different input on your TV.

tried all of those … actually each one separately, and then all together …!
I can’t see anything that has changed.

https://paste.osmc.tv/exafebewaq

I thought maybe it was the HDMI cable (which is the same one that was working). I cleaned both connectors with spray contact cleaner - but no change :frowning:

Tried swapping the HDMI cable, and used the XBOX HDMI cable instead.
Same problem.
I think there’s a ‘factory reset’ for the TV, so I might try that.

Has this ever worked with this TV?

Rx Product Name: SAMSUNG
Manufacture Week: 45
Manufacture Year: 2009

A lot of TV’s made a decade ago didn’t come with very good CEC implementations.

Yes. It was working perfectly. For several years. I have used it woth every Gen Vero and several RPis. In fact this TV was used with Raspbmc on a Pi…

It looks like you haven’t updated this device for a while prior to the November update?
If you stop Kodi and run:

cec-client

What’s the output?

Sam

On Vero 4K+ with HDMI connected:

osmc@osmc-Ulysses:~$ cec-client

No device type given. Using 'recording device'

CEC Parser created - libCEC version 4.0.1

no serial port given. trying autodetect: FAILED

osmc@osmc-Ulysses:~$

On another Vero 4K+ with no HDMI connection:

osmc@osmc-Cavendish:~$ cec-client
No device type given. Using ‘recording device’
CEC Parser created - libCEC version 4.0.4
no serial port given. trying autodetect:
path: /dev/aocec
com port: AOCEC

opening a connection to the CEC adapter…
DEBUG: [ 191] Broadcast (F): osd name set to ‘Broadcast’
(this just hangs here)

Thanks!

Hi Niall,

From the libCEC versions, it looks like those systems are on different verions.
Can you post a log from Ulysses? I’m suspicious libCEC has been installed from another source.

Hi Sam,

Here’s the cec-client output from ‘cavendish’, with HDMI connected.
TV has 4 HDMI inputs. I tried HDMI1 and HDMI2. Same response.

osmc@osmc-Cavendish:~$ cec-client
No device type given. Using ‘recording device’
CEC Parser created - libCEC version 4.0.4
no serial port given. trying autodetect:
path: /dev/aocec
com port: AOCEC

opening a connection to the CEC adapter…
DEBUG: [ 130] Broadcast (F): osd name set to ‘Broadcast’
NOTICE: [ 130] connection opened
DEBUG: [ 130] processor thread started
DEBUG: [ 130] << Broadcast (F) -> TV (0): POLL
TRAFFIC: [ 130] << f0
DEBUG: [ 2165] >> POLL sent
DEBUG: [ 2165] TV (0): device status changed into ‘present’
DEBUG: [ 2165] << requesting vendor ID of ‘TV’ (0)
TRAFFIC: [ 2165] << f0:8c
DEBUG: [ 5205] expected response not received (87: device vendor id)
TRAFFIC: [ 5205] << f0:8c
DEBUG: [ 8245] expected response not received (87: device vendor id)
NOTICE: [ 8245] registering new CEC client - v4.0.4
DEBUG: [ 8245] detecting logical address for type ‘recording device’
DEBUG: [ 8245] trying logical address ‘Recorder 1’
DEBUG: [ 8245] << Recorder 1 (1) -> Recorder 1 (1): POLL
TRAFFIC: [ 8245] << 11
DEBUG: [ 10285] >> POLL sent
DEBUG: [ 10285] logical address ‘Recorder 1’ already taken
DEBUG: [ 10285] Recorder 1 (1): device status changed into ‘present’
DEBUG: [ 10285] trying logical address ‘Recorder 2’
DEBUG: [ 10285] << Recorder 2 (2) -> Recorder 2 (2): POLL
TRAFFIC: [ 10285] << 22
DEBUG: [ 12325] >> POLL sent
DEBUG: [ 12325] logical address ‘Recorder 2’ already taken
DEBUG: [ 12325] Recorder 2 (2): device status changed into ‘present’
DEBUG: [ 12325] trying logical address ‘Recorder 3’
DEBUG: [ 12325] << Recorder 3 (9) -> Recorder 3 (9): POLL
TRAFFIC: [ 12325] << 99
DEBUG: [ 14365] >> POLL sent
DEBUG: [ 14365] logical address ‘Recorder 3’ already taken
DEBUG: [ 14365] Recorder 3 (9): device status changed into ‘present’
ERROR: [ 14365] AllocateLogicalAddresses - failed to allocate device ‘0’, type ‘recording device’
ERROR: [ 14365] failed to find a free logical address for the client
ERROR: [ 14365] failed to register the new CEC client - cannot allocate the requested device types
unable to open the device on port AOCEC
ERROR: [ 14366] failed to register a CEC client
DEBUG: [ 14366] unregistering all CEC clients
osmc@osmc-Cavendish:~$

On Ullyses, I had installed lib-cec (or utils, I don’t remember which). That might explain the different version.

Also I did factory reset on the TV.
And still the same…

It’s weird … I seem to have eliminated everything, but I still can’t see what the issue could be?

Logs from Ulysses
https://paste.osmc.tv/uturodosip

Logs from Cavendish:
https://paste.osmc.tv/sukiheseji
Thanks!

Ah.

If you’ve installed libCEC from apt you’ll break CEC functionality entirely

Run

dpkg -l | grep libcec

sudo apt-get remove on any packages not suffixed with -osmc

Then reboot

Sam