Cec adapter

i am getting issue with CEC
Pulse-Eight CEC apaptor
CEC adaptor couldn’t initialise
after kodi boot on, is the original cable that is shipped with vero4k cec compatible? thank you.

can i provide some logs to resolve issue?

Yes — the original cable is compatible.

There is a small chance, as with anything that it is defective. Have you tried another cable?

havent try other one, dont believe its cable issue, any chance to debugg it? it should work without any setup ? its connected to marantz sr6012

Try connecting directly to the TV first.

dont have TV only projector + avr :slight_smile:

Then try connecting to the projector directly.

exactly same error, with different cable directly to projector, whats the poin to do that blind testing? there are mo logs?

What is the make and model of the projector?


panasonic pt 4000 ; but its not working with receiver also … so dont think its projector issue…

so any idea?

Does the manual show it supporting ‘Viera Link’? That is their name for CEC.
Can you post some debug logs so I can look in to this further?

Are you able to try a different cable?


manual of projector?

what is viera link? i am bit confused.

What logs? could you point me to location? yes i can share these.

I tried 2 cables, vero4k original one, and mine cable.

Viera Link is the brand name for CEC on Panasonic devices.
See How to submit a useful support request - General - OSMC

yes my machine should support it.

also receiver comes with cec support - marantz sr6012

not sure if i understand it properly:
i have cec compatible AVR, into that avr i plugged vero4k as an input and hdmi out is projector. I wanted to control vero4k (playback) by AVR’s remote controller.

pls find attached logs:

So what is the purpose of the ‘pulse-eight CEC adapter’?

well not sure, i might not understand cec properly then. i thought i will be able to control vero4k using AVRs controller. am i wrong?

It’s just how the CEC interface is described.
Pulse-Eight are the developer of libCEC.

This is the problem:

19:34:41.705 T:3938448128 ERROR: CecLogMessage - AllocateLogicalAddresses - failed to allocate device ‘0’, type ‘recording device’
19:34:41.705 T:3938448128 ERROR: CecLogMessage - failed to find a free logical address for the client

Do you have other devices connected?
The CEC is a 1 wire bus with limited peripheral space. Changing the Vero to a player under CEC Settings may fix the issue.

I suspect if you unplug other devices as a quick test and reboot, CEC will work

You could also try changing the logical address.


hi sam,
other devices to AVR? yes around 4 devices + vero.

What is it - changing the vero to player? i dont get it.

how can i change the logical address? i am confused… does it mean there is some CEC dev collision on AVR side?

Yes — there’s a collision.
With CEC you can only have a finite number of Recorders, a finite number of players.

As a quick test can you disconnect some devices and power cycle TV and Vero? If this works it will be a simple enough fix