Cec-client - November update

After upgrade cec-client stopped working:
bash: cec-client: command not found

running manually /usr/osmc/bin/cec-client:
libcec.so.3.0: cannot open shared object file: No such file or directory Cannot load libcec.so

In /usr/osmc/lib/pkgconfig/libcec.pc:

dpkg -l | grep mediacenter-osmc ii rbp2-mediacenter-osmc 15.2.0-8 armhf Media Center package for OSMC


Did you look at the two CEC related threads in this subforum that are less than 24hrs old?

This is about rbp1: OSMC November Update - Samsung CEC - #59 by mamam
Mine is an rbp2 related issue, i dont see the other one. :frowning:

Thanks for bringing this to our attention. This is due to moving many custom lib files to /usr/osmc/lib. We will have to think about the best way to solve this, whilst still retaining the custom lib location.

Also getting this with cecanyway on rp2 with build against libcec 3.0.1. Fix to config would be appreciated.


Hi, I have a problem with my CEC on rpi1…after update…cec doesnt work any more…but it is new update allready out…how can I run it without cec…my rpi1 provide me new update…but I must confirm this update…but I dont have a cec or I dont have a keybord or mouse checked under setting…I allready run on ssh sudo apt-get update…but it is still the same…question is how can I run update without cec or mouse/keybord

sudo apt-get dist-upgrade

There is no point in doing a dist-upgrade, as this hasn’t been fixed yet.

Is there a reason this is not straightforward to fix? Packages have been moved to /usr/osmc/lib, but no such library is listed in /etc/ld.so.conf.d, so these packages cannot be linked to. Should there not be an osmc.conf for this new library location?

At the moment none of the packages in /usr/osmc/lib can be used…


ok, but how can I get CEC back…I read on this forum, this issue is allready fixed…but I cant run last update because cec doesnt work…I allread run sudo apt-get dist-upgrade and we will see if CEC will be fix

People in this thread are mixing up two different issues.

This thread is talking about the command line tool cec-client - this is not working at the moment and we are aware of this.

CEC in Kodi is working however - there was a CEC problem with the initial November release on the Pi 1 which was quickly fixed and updating again should fix the issue. If you are having problems with CEC within Kodi please start a separate thread of your own.

Yes I know this is the wrong thread…but the correct one is allready locked OSMC November Update - Samsung CEC - #66 by Jens_Vedel_Markussen

I can open new one…but I didnt want to open a new thread for simple question…how to run osmc/kodi update without cec…

p.s. now it is work…fix:sudo apt-get dist-upgrade

So start a new thread instead of thread-jacking this one.

1 Like

I’ve just upgraded and faced the same issue. As @DBMandrake states the library has been moved to another location: it is in the system but kodi just can’t find it. For the time being I have fixed the problem like this:

ln -s /usr/osmc/lib/libcec.so.3.0 /usr/lib/libcec.so.3.0

1 Like

Or create a file (as Amos mentioned) under /etc/ld.so.conf.d e.g. osmc.conf with this content: /usr/osmc/lib
and run ldconfig

If Kodi cannot find it you have an out of date version of Kodi that did not update for some reason. Please try updating again and if the issue persists post full debug logs.

@sam_nazarko Is there any update when the fix that was applied for rp1 is going to be apply for rp2?

If you are referring to the issue where Raspberry Pi 1 did not have working CEC after updating, this has been resolved.

The cec-client issue has not been fixed for Pi 1 or Pi 2 yet.


Yeah, I’m referring to the cec-client issue. Thanks

This has been resolved and will be in the December update: