My remote is not working via HDMI-CEC. I’ve got installed latest update (December).
I’ve got compatibile HDMI cable connected directly Raspberry Pi2 to my TV (Samsung UE50HU6900S). I tried to type “cec-client” in SSH but I just got “command not found”. I thought it will be fixed in December update.
Any thoughts?

  1. Is your CEC Device (TV) shown under the input devices in Kodi?
  2. Enable debugging and provide logs How to submit a useful support request - General - OSMC
  1. Settings → input devices → Peripherals? There is CEC adapter.
  2. http://paste.osmc.io/cocebalefa

Check the URL, that one is an empty document

Sorry double pasted. Working url: http://paste.osmc.io/cocebalefa

Are you using an USB CEC adaptor?

LoadMappings - loaded node “iMON HID device”

No. I’ve got other device (TV decoder) which works just fine with CEC.

1 Like

try with another HDMI cable…

I tried. Even the one that works with TV decoder.

What about cec-client command? Why do I get “command not found”? Isn’t that build in libcec package?

Same here. The CEC adapter is showing under peripherals, and my PI 2 is accepting CEC commands and passing through to my TV, but i cant find the cec-client under the osmc user, or root. Perhaps its named something else now?

sudo apt-get install cec-utils

1 Like

Note that if you use ceclient via commandline, you will most likely kill the kodi internal one. In this case you will need to restart kodi after killing the one you are running manually.

After yesterday update and reboot my remote is working fine. Still no cec-client command, but most important that remote is working.

cec-client is at /usr/osmc/bin/cec-client. It is not in the default path.

And yes, using cec-client while Kodi is running will kill CEC in Kodi until a reboot.


Following another OSMC forum, i did the following and got CEC-Client to work.

Created a symbolic link to libcec.so.3.0 by running the command:
ln -s /usr/osmc/lib/libcec.so.3.0 /usr/lib/libcec.so.3.0

Then running the CEC-Client by going to the path mentioned by DBMandrake, and entering the following command:

osmc@osmc:/usr/osmc/bin$ ./cec-client

I am not sure why you needed to create a symlink. For me on my standard OSMC installation cec-client works out of the box

osmc@osmc.hongkong:~$ /usr/osmc/bin/cec-client
No device type given. Using ‘recording device’
CEC Parser created - libCEC version 3.0.1
no serial port given. trying autodetect:
path: Raspberry Pi
com port: RPI

opening a connection to the CEC adapter…
DEBUG: [ 59] Broadcast (F): osd name set to ‘Broadcast’
DEBUG: [ 60] InitHostCEC - vchiq_initialise succeeded
DEBUG: [ 60] InitHostCEC - vchi_initialise succeeded
DEBUG: [ 60] InitHostCEC - vchi_connect succeeded
DEBUG: [ 61] Open - vc_cec initialised
DEBUG: [ 61] logical address changed to Free use (e)

Out of the box i get :

osmc@osmc:/usr/osmc/bin$ ./cec-client
No device type given. Using ‘recording device’
libcec.so.3.0: cannot open shared object file: No such file or directory
Cannot load libcec.so

Update your system.

This has already been fixed in the December update.

Hi @DBMandrake ,

And yes, using cec-client while Kodi is running will kill CEC in Kodi until a reboot.

Is there a way to enable CEC for Kodi without a reboot after using the cec-client?

Thanks for your help.