CEC commands delayed and duplicated (LG TV)

Hey, when Kodi 19 was released for the Vero a year ago I immediately noticed a CEC problem. Sometimes when pressing a button on the LG Magic Remote, the CEC command is delayed for about 1.5 seconds and is also duplicated. It is of most annoyance when I want to jump back just 10 seconds while playing a video, but instead it jumps back 30 seconds as if I had pressed the left button twice on the remote. This issue has never been there with Kodi 18 and also has never shown on my other Vero 4K+ connected to a Philips TV. So it seems something with the CEC adapter changed that is causing problems on LG TVs. When I connected my other Vero to the LG TV the issue also appeared. Changing HDMI cables didn’t help either.

I uploaded some logs
After enabling debug logging I restarted twice. After that I just navigated down once to highlight TV Shows library, then clicked OK to enter TV Shows library, waited ca. 10 seconds and then clicked down one more time to navigate down to the next TV Show. That was the moment when the delayed/duplicated CEC command happened. Instead of navigating down one time, the command was delayed and then executed twice, effectively navigating down two times.

I think for CEC logging, you need component specific logging enabled in Kodi, rather than debug logging.

Have you tried:

  • Power everything down at mains for a few minutes?
  • Make sure only Vero is connected to the TV?
  • Seeing if you can reproduce the issue with another device connected to that LG TV?
  • Checked if the LG TV has some firmware updates available
  • Everything has been powered down multiple times completely since this issue first appeared.
  • I didn’t try to disconnect all other devices, but I don’t think that’ll help, because before Kodi 19 this issue wasn’t present and nothing in my setup changed.
  • My Apple TV and a Fire TV Stick are working without any CEC issues
  • TV firmware is up to date

I will post another log tomorrow with the proper logs enabled.


Would appreciate if you could try with devices disconnected and upload some logs.


I guess after enabling component-specific logging I need to specify Verbose logging for the libCEC library. Is that correct?

That’s correct, yes.

Alright, will do tomorrow. Thanks

1 Like

So I disconnected all other HDMI devices and pulled the plug of the whole power strip and reconnected the power strip after 3 minutes. This time I started playing a video and after letting it play for ca. 15 seconds I pressed left on the LG remote: CEC command was delayed and duplicated. Instead of jumping back 10 seconds, the clip jumped back 17 seconds to the beginning of the video. Then I let it play for some seconds again and pressed the OK (middle) button on the remote. Same behaviour again: delay and then duplicated CEC command which resulted in bringing up the player menu (first OK button command) and clicking on pause (second OK button command).


I can spot some of these
cectx c810023c.aocec: cec unsupported cmd:0x87, halflg:0x0
cectx c810023c.aocec: bus confilct too long (There seems to be a typo in this string)
The bus confilct too long error is the one that at least fits the first timestamp when I pressed the left remote button at ca. 11:33:20 (UTC+1)

I’ve only seen this with a bad cable on my LG TV.

I’ll try another cable that I bought a couple of weeks ago, which should be a proper one. But I wonder why this never happened on Kodi 18 with the same cable. Can you see anything else in the logs?

The other cable didn’t change a thing.

As this continues to be very annoying, is it possible to downgrade the CEC adapter to the version that was used in the latest Kodi 18 version?

libCEC hasn’t seen significant changes in the last few years and I would be surprised if your issue is there. Instead, I’d suspect that your issue may be due to a TV firmware upgrade.

If you can eliminate the issue with an older version OSMC, then I can look in to this further but would be surprised. Have you introduced any new peripherals in to the chain?

I did a tidy up of CEC behaviour in our new video stack which we will introduce soon and I’ve sent you an invite to that PM now. You will need a USB or SD card to test.



I reverted back to Kodi 18 after I couldn’t get rid of that issue a year ago. Then months later I tried Kodi 19 again and the problem came back immediately. And as suggested by you, I disconnected all the other devices from my TV and that didn’t change a thing, neither did swapping cables.

Please try the image in the PM I’ve sent you



This might be a weird coincidence, but this morning there was an update for the TV and until now, the described issue hasn’t shown itself today. If it comes back I will give that custom image a try. Is there a preferred method? USB or SD card? Btw in Chrome neither download button worked, only the direct link. In Firefox both buttons worked though.

You can use whichever medium you prefer. No real difference.