CEC constant battle

I’m still having issues with CEC.

Two hdmi cables (both work fine with STB) different hdmi ports.

When I turn off TV CEC on vero stops responding. Sometimes it starts working after rebooting Vero but most of times I can’t get it to work.

My log is uploaded to Https:/paste.osmc.tv

Please help me.

You need to provide full link to the log: letters after the last slash also.

Could you let us know what all your settings are in…

settings>system>input>peripherals>CEC adapter>

These are all default.

Tried turning everything apart from “Enable” switch but there is no difference.

Logs uploaded to

All worked this afternoon but now not working again.

Thanks for helping me.

Is your Vero plugged directly into the TV? If you change to a different input and then back to the one the Vero is connected to does this make a difference?

It’s direct connection.

Changing ports does not make any difference.

Both ports are working fine for CEC for cable TV box.

Tv is Samsung 2017 model

He meant for you to adjust the TV to another input for a moment, then switch back and see if there were any effect.

1 Like

It does not work either.

While it’s not likely to solve your issue, this video is pretty relevant and informational re: the very different implementations of CEC.

You might try changing the physical address in the CEC settings to 1, 2 or 4 and see if that makes a difference. You will need to at least reboot the Vero after changing this setting for it to take effect. It may be possible that you may need to go one step further by unplugging the power from the wall for the TV, Vero, and your cable box for a few minutes to completely reset the CEC network.

On an unrelated note you may be well served by turning refresh rate switching to on/off and color range to limited.

I had the same problem before. To get vero to respond again I had to turn on and off my digital tuner and then vero worked until I turned off the tv again. I had this problem for a couple of weeks and I think it vent away after a sw update.

I think it’s funny that the people with high end TVs like Samsung and LG seem to have so many problems with CEC.

I have a cheap Hisense and Sanyo. They work perfect with CEC. Sometimes the best isn’t really the best…

I suspect it has something to do with the premium brands maybe doing something proprietary “improvements” under the hood that are pushing the limits of the CEC standard Wich very outdated as it is. And that is causing compatibility issues.

I don’t think so.

It worked fine for more than a year and then stopped after one of osmc updates. I was able to get it going by pulling cables out etc but now just stopped alltogether…