CEC Control not working - Vizio E50-E1 - After TV OS Upgrade (

Device: RPi 3B
OSMC: 2017.10-1
Attached Peripherials: A USB Joypad Controller

Kodi Log with CEC Debug enabled:

Prior to upgrade of Vizio firmware (out of the box) CEC was working albeit only if the TV was running prior to booting RPi / OSMC.
I don’t recall the previous version number, but 3.23.xx sounds about right.

I know OSMC is a bit old, but I want to maintain the Jessie train as I have a Retropie install and it will not setup/install on Stretch. As long as there have been no changes to the CEC Library there shouldn’t be a difference.

As an aside, when hooked up to a Samsung TV, the CEC controls function as expected.

OK, so I found this post:

I figured what the hell, I can change some 1s to 4s and see what happens.

Everything seems to be working now. I can control the menus, it even persists control after power cycling the TV and changing inputs where previously that was an issue.

I’m not sure what device_type “4” is vs “1” but it seems to have solved my issue.

Edit: Looks like device type 4 is “Playback Device” (Source)

typedef enum cec_device_type
} cec_device_type;

Do you have lots of CEC devices connected to your TV?

No, I have just the OSMC device. I have 2 other devices connected via HDMI: Xbox 360 & Nintendo Switch. Neither are CEC compatible as far as I know. Also, neither were powered on.

Same thing happened to my Vizio a few weeks back:

Interesting. My first experience with a Vizio device but the price point was right.
The customer service was HORRIBLE btw, I tried to get a rollback binary for the firmware… It was like I had 3 heads and was speaking Mandarin. But I also get rubbish service from Samsung so… at least I saved a few bucks?

Anyway this seems to be the ticket for the fix, glad I stumbled on it. I was about to take the the screen back and try a HiSense panel… which I really didn’t want.

Sorry to hear about the experience, but thanks for sharing this information. It will likely help others in the future

If any of you are up for some testing, I may be able to improve out of box behaviour for users in the future


I have a P75, replaced twice… (first time because of the backlight had a “dead” column and the second time because the TV was rebooting on its own). Having said that, the image quality is truly outstanding.

I’m always up for a little testing. Mostly because I will probably learn something new.

Looks like RetroPie has made some stretch updates. I’m going to try updating my image this weekend. Would be a good time to do any CEC testing if you still want me to try something.

You could try: HDMI-CEC some buttons not working on Vero2 that do work on Pi2 - #8 by sam_nazarko


Hey Sam, thanks for the suggestion, but the fix in the thread referenced was ultimately a new hdmi cable. The Samsung post I found fixed my issue I thought you wanted me to test something else out.

Feature request… (HI Sam!). Gui CEC submenu for switching between different CEC flavours.

1 Like

There was already a plan to add a menu to add support for two different roles, but this would be as far as the scope of settings would go at this time


1 Like

Ooh +1