CEC "double-press" woes

Hi there !

I received my V today, and it became clear from the get-go that configuring it would be painful, seeing as I get double-inputs rather often (and painful it definitely was… and still is).
I don’t have issues with missing button presses, though, as I saw in some threads.

As seems to be one usual suspect, my TV is a Panasonic, circa 2012.

I’ve tinkered with some settings (in Settings → Input Peripherals → CEC), to no avail:

  • CEC Client Device Mode: tried them all (rebooted every time), even Tuner, because why not ?
  • Remote Button Press values: tried a bunch of values (including everything maxed)

For context, a couple years ago I’ve tried some “recent” distros (typically OSMC, LibreElec) on a RP2, and had the same issues.
I thus stayed on my RP1 with its good ol’ Kodi 14, which works perfectly on that matter (not so much on hevc content, though :sweat:).

I take it it’s one of those issues that just never go away ?
Would using some of those lircd files in OSMC/Remotes change anything ?
I also have an ages-old Pulse-Eight USB-HDMI “dongle”, and plugging it in didn’t change much, but there might be some more steps involved I’m unaware of…

From the top of my head, there’s an option to change the repeat delay in Settings → Input → Peripherals → CEC.

This might help.

Unfortunately not as CEC isn’t related to LIRC (used for IR remotes)

If you place a book or something in from the Vero V to block IR from hitting the front of it does the double key presses stop?


I’m wishing out loud, but would it be possible to disable CEC and recognize a selection of buttons from my current IR remote, using whichever lirc setting ?

I’ll give it a try when I get the occasion.

Possibly – depends on the model of remote.

Well, it doesn’t :pensive:

And this situation is for sure CEC? So does this mean it only happens if your using your TV’s remote to control Kodi and if you use the OSMC remote there isn’t an issue? The reason I ask is that I don’t remember hearing about double presses coming from CEC. I have seen it with lirc which is why I had you block the IR receiver just in case you were using one of the TV remotes that actually send IR commands instead of using CEC for connected devices.

I take it that just disabling CEC in your TV’s settings isn’t a particularly desirable option? If you were getting this rather unusual behavior on a RPi running LE it seems like maybe your TV isn’t following the CEC specifications particularly close. That, or perhaps there is some kind of defect in the electronics involved inside the TV.

To clarify:

  • Remote is working as expected on the TV (outside of CEC operations)
  • No issues at all on RPi1 with Kodi 14 (in case the version matters somehow)
  • Issues with RPi2 (and now Vero V), whichever the Kodi 17 (IIRC) distro (can’t say I tried them all, but it seemed rather obvious)

It is possible that with those old versions there were tweaks made for compatibility with some TV’s that have since been removed. Historically manufactures often did a poor job making their CEC implementation fully compatible outside of their ecosystem. The situation seems to have improved in recent years but it is still very much a “CEC is great when it works” type of situation. I’m not sure there really is a solution in your case other than just turning CEC off either on the TV or in Kodi and just use a different remote. If your hitting a button on your TV and your TV tells kodi to perform a function twice how would it know if it really should be doing that or not? You said you had adjusted the timing in Kodi’s CEC settings to the max without success so I’m not sure what other setting could be tweaked to try to work around the issue.

That’s a good point.

For science I did try to replace the current libcec.so.6.0.2 with ye olde libcec.so.2.0.1 (which is actually reported as being 2.2.0 in Kodi :person_shrugging:) from my Helix, but as expected, it didn’t go too well.

Would there be a way to add that specific lib version ?

Alternatively, I tried to find what makes Kodi 14(.2, IIRC) so different for my specific use case.
There could be a possible hint there:

Includes libcec double-key suppression.

Unfortunately, that repository doesn’t exist anymore in chbmuc’s GitHub, and it’s not on web.archive.org either…

I found some seemingly relevant info in Pulse-Eight’s commit history, and the date looks coherent, but I have no idea if that could be it (or even if it’s actually the most relevant commit)…

The commit is at the following link and it does seem to explain the situation you facing (ie your TV is bad at CEC :grin: ) but what exactly can be done with this information would need to be evaluated by someone who could better understand what changes were made there. I’m not a programmer.

You can’t downgrade libraries like that unfortunately, it will at best give you an error and at worst crash Kodi.