CEC functions changed


I recently upgaded (fresh install) to the last OSMC version from april and since then my TV remote does not control the OSMC/Raspberry as it used to. Specifically when playing a movie, the ‘select’ button (in between the cursorbuttons) does nothing and it used to bring up the player controls.
Can this be fixed?



Which version did you update from?
We haven’t changed anything CEC related in a long time.

Did your TV get a firmware update recently?

Hi Sam,
Thanks for responding so fast. The previous version I used was 17.6 (compiled feb 4,2018) and in myOSMC it says ‘oktober 2017.10-1’. With this version the remote works fine.
The reason I did a fresh install of OSMC is that I got an error message trying to update: something to do with tdb-tools. And the movie-scaper did not work anymore. After some fiddling it did, but without getting images like fanart etc. That all works fine in the newer version.
Note that the mentioned button form my remote is only not working while playing a movie. I can skip and go back with the arrowkeys, but the ‘select’ or ‘enter’ does not respond. No update for my Samsung TV (not connected to internet). So I looks like a player issue to me.
I just re-inserted the SD with the old version and there it is no problem.
Hope this helps.


Try power off the Pi and Samsung at the mains for 5 minutes.

That did NOT do the trick. And since exchanging the SD with the old one restores functionality, I did not expect it would. But I tried. No success.

Can you post logs from the old SD and the new one so I can compare package versions?

Most CEC issues are solved by a power down, so it was worth testing. I assume you’ve checked that Kodi settings are the same on both SDs? You could copy the ~/.kodi directory over from the old card to the new one.


Okay. Where do I find the logs?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.


I generated the loggings; you can find them here:
previous working version=
current faulty version=

Hope this all works. By the way: the problem is the same when I use the SYBU app on my iPad: the ‘OSD’ button does not react when playing a movie. All the rest is fine.



Can’t really see why the functions would have change, but try put back as they were with:


Thanks Tom.

Thanks for the tip. Tom. Unfortunatelly that did not do it either. Taking into account that the button OSD on the SYBU app also has no effect anymore, the problem is somewhere else. I had a look in the logging and found this:

23:16:56.980 T:1767895808 DEBUG: PushCecKeypress - received key b duration 0 (rep:0 size:0)
23:16:56.980 T:1767895808 DEBUG: PushCecKeypress - added key b
23:16:56.996 T:1925786112 DEBUG: OnKey: 11 (0x0b, obc244) pressed, action is OSD
23:16:56.996 T:1925786112 DEBUG: ------ Window Init (VideoOSD.xml) ------
23:16:56.996 T:1925786112 INFO: Loading skin file: VideoOSD.xml, load type: LOAD_ON_GUI_INIT
23:16:57.003 T:1925786112 ERROR: unable to load:/home/osmc/.kodi/addons/skin.confluence/720p/VideoOSD.xml, Line 105
Error reading end tag.
23:16:57.003 T:1925786112 DEBUG: ------ Window Deinit (VideoOSD.xml) ------
23:16:57.305 T:1767895808 DEBUG: PushCecKeypress - received key b duration 325 (rep:0 size:0)
23:16:57.305 T:1767895808 DEBUG: PushCecKeypress - ignored key b

Obviously something is wrong in this file of interpreting it. Any suggestions?


I found some NUL bytes in the VideoOSD.xml and removed them, but that did not work at once (no reboot). Then I ‘updated’ (no version change) the Confluence Add-on and mow I do get the OSD, be it not completely. But I think I am on to something here… :slight_smile:

Happy to announce that after a reboot everything is now fine.
At least I know how to debug now, so I don’t have to bother you right away when something comes up :slight_smile:

Thanks for your time and assistance!


1 Like


Glad to hear its sorted.

Thanks Tom.

1 Like