CEC glitches

I don’t think there is anything special about my CEC settings, but here you go. The AVR is an old NR1603, the TV as well is pretty ancient.

Great, thanks. I have the NR1608 and the TV is an ST60 (Plasma). I have a feeling my issue is connected my amp’s video passthrough on standby. I can’t seem to find if your amp has the same passthough. 1602 doesn’t but 1604 does.

My 1603 has an “HDMI Control” setting switched to On, which I think enables the passthrough you mention, among other things, though thinking about it I have no need for passthrough so might be wasting power. The corresponding “Power Off Control” is set to Off. Whenever I switch on the TV the AVR will come on if it’s not already on, I rely on the AVR’s auto stand-by to switch itself off. The 1603 is running a firmware update released earlier this year, surprised that Marantz are still supporting it.

I’m confused about the HDMI settings; I would have thought HDMI Control is the ability for the amp to receive control commands from the TV (ie volume, power) . I have these other options for passthrough:


I think it’s the passthrough that causes my Vero to switch back on. Can you watch the Vero with your amp switched off?
btw sorry to invade your thread, I hope your issue gets sorted too!

I’ve checked the manual and the operation of my NR1603, and the HDMI Control setting enables both power-on triggers from other devices as well as passthrough. You can see from this shot that the 1603 has a more basic menu than your’s. I have never before checked passthrough in standby as TV sound is always routed through my main front speakers and I need the AVR to be running its pre-amp output into the external front amp with volume control via the TV. However, I did just check, and passthrough works.

You might be interested to know that when I switched HDMI Control off, as well as losing the ability for the TV to turn on the AVR, I also killed CEC to the Vero. I had to re-boot the Vero to get it back.

In the meantime, the OSMC Pi running to my kitchen system is behaving itself as well as the LE Pi did, whereas the Vero was just a non-starter in terms of CEC reliability, although in my other systems Vero/Panasonic combos are fine.

1 Like

Sorry for the late reply. Can you try the instructions here: HDMI-CEC some buttons not working on Vero2 that do work on Pi2 - #14 by lichtus

Sam

thanks, can you point out the specific change I should make? Looks like I need to chase down an xml file?

Yes — if you scroll up from above post you should see the detailed infob

The thread you linked me to appears to suggest that a device_type key be changed to a value that mine is already set to. Here are some potentially relevant keys from my V4K+, should I be changing any of these in the peripherals.xml file?

<setting key="tv_vendor" type="int" value="0" configurable="0" />
 <setting key="device_name" type="string" value="Kodi" configurable="0" />
 <setting key="device_type" type="int" value="1" configurable="0" />
 <setting key="wake_devices_advanced" type="string" value="" configurable="0" />

Just wondering to what extent there might be any chance of resolving the CEC compatibility issue I have with the Vero/speaker bar combo that does not occur with OSMC or LE Pi’s. in the meantime I have unwrapped a Vero remote for the first time (nice little thing) and I have a good connection, but it means I have an extra remote to have around that I don’t otherwise need when running a Pi. The benefits of the Vero can offset the minor inconvenience, but my inner geek is bugged by not knowing why CEC is better with a Pi, albeit in only one problem case out of the three systems I’m running.

I suspect that changing device_type will do the trick.

The Pi and Vero CEC implementations are almost identical. However the Pi will behave as a Recorder and the Vero will behave as a Player. By changing the device type you can unify this behaviour.

Sam, you’ve mentioned this a few times but never said what I should change the device_type key to. I just checked, my OSMC Pi has the same peripherals.xml entries as I previously posted for my Vero. So what should I do?

4 would be worth trying.

Just to confirm: this issue only occurs when you turn the TV off? Are you standbying the device?

Tried changing the device_type to 4 in both the central peripherals.xml file and, when that did not work, in the .kodi/userdata version, and neither fixed it. I had taken the trouble to stop Kodi first per the Wiki instruction.

Behaviour is as follows. With a Pi, I put the TV in standby (it’s never switched off), when I come back, one of two things happens: either the CEC is working, or if not, a quick switch away from the speaker-bar HDMI input and then back immediately wakes up CEC, and all is well.

With the Vero, I can get CEC to work after a boot, but if I put the TV in standby for around 10mins or so, when I come back CEC is totally broken, I have to reboot the Vero and cycle back and forth on the HDMI input and then CEC resumes, but only until the TV is next put into standby. This has not gone down well so either I use the Vero remote or go back to a Pi. The Vero’s technical advances over a Pi aren’t really needed for my kitchen system, so the Pi will probably be the option for now as it’s a little less hassle, but would be nice if we could get to the root cause of the problem.

Thanks for explaining. Try enabling HPD Lock and rebooting

Thanks, but unfortunately enabling HPD Lock has not fixed it.

I’m not sure then unfortunately. Your log here: https://paste.osmc.tv/sebuyupoko shows CEC working and presses being received.

Sam

As I recall this log started after a boot with CEC working, which I think shows in the log, then I turned off the TV for a while and when I switched it back on, CEC no longer worked.

Does your TV have one of those menus that show if CEC devices are connected? It’d be interesting to know if the Vero disappears.

The TV is of around 2010 vintage and the menus are quite basic, so I don’t have much more to go on.