CEC issue on a LG tv

I´ve been using OSMC for quite some time already in a RPI2 model B with success so far.
Last couple weeks ago I notice the my TV remote control was not working anymore. But since I had brought a RPI4, I let to get in that matter if it arise on the new system.
So, with a RPI4 in hands, I decide to do a fresh install, not even restore the backup that I made every week for a couple years…
And the problem arise. Not a single button work. Although, when I enable the logging, I can see the keys being pressed.
The CEC option is set, I don´t see any option similar in my TV settings menu.
I have a LG TV UJ7500 and was working a few months ago.
And I tried a few different remote presets in MY OSMC program.
Here are my logs: http://paste.osmc.tv/efoyaluwiz
Thanks a lot for this guys,

Which version of OSMC were you using on the Pi 2?
Are you using the same port on the TV?

It’s possible your TV got a firmware update.

You could try powering all devices down at the mains for a few minutes.

Tried that. I would leave for a couple days, so I let everything off, from the outlet…

Turned on the TV first, selected the HDMI port and than turned on the PI. Watched everything turned on just as it should be. Minus the CEC. Although it is loading correctly, apparently, the remote control does not work.

Yes, is the same port as I used to use. Even the cable is the same. I did a test with a different cable, but failed too.

thanks a lot for your help Sam. I´ll keep investigate and if you have another idea or an idea of what can I do to investigate I appreciate it.

Those have no effect with CEC control

I can’t wrap my head around how this could be the case. Not only is the log showing it receiving the handlekey events but it also shows the windows activating and deactivating in response to the button presses. Do you still have the old RPi plugged in and somehow your looking at the video from the old one while the TV is talking to the new one? Maybe something to do with having an ARC enabled device plugged into the wrong port of the TV?

No. To be honest, I just heard about those ARC devices and then went to learn what it is. Perhaps some mis configuration on my TV regarding these aspect. I´ll take a look.
Indeed I saw the log and see the handle keys appearing while testing. I´ll keep investigating and update this post accordingly…
Thanks Darwin!

In the past I’ve accidently plugged my AVR (that supports ARC) into the wrong input it forced the TV to switch to the wrong input on playback start and it just so happened that I had multiple OSMC devices plugged in at the time which quickly became quite confusing which I was looking at. If you don’t have another Kodi box that can be mistaken for the RPi 4 this wouldn’t be a valid path to follow, but I figured I’d mention it just in case.

Sorry for the delay in get back here.
I decided to relocate my wi-fi router and for that I need to make a few cables for my TV setup. One of then for my Kodi RPI. And, like magic the remote control starts to work.
I don´t know what happened, I just change the router position to a more high one and change the ethernet cable.
Just want to make sure to close this thread and not leave something unanswered…
Thanks for all your help. I did learned a lot about those HDMI Arc though.

1 Like