Cec issues

since the update to Krypton the cec stuff seems to be acting a bit funny, its set to power down the tv on shutdown which it does kinda, it powers down the tv as the pi is shutting down but the tv turns back on afterwards which it never used to do before the update. i also noted if i went in to the cec settings and change anything the pi stops working with the tv remote.

same here. also if i switch tv off then back on the tv remote stops working with the pi. the only way to make it work again is either by switching to another input on the tv then switch back to the pi input or by disabling and reenable cec.
i have already reinstalled osmc from scratch and still the same.
it worked perfectly fine with kodi 16 and i am starting to regret i have updated.

1 Like

Could you please post full debug logs to help diagnose the problem?

i thought it did turn the tv off, but the screen just goes black during shutdown without turning the tv off. so to be clear its not switching the tv off at all, and if a setting is changed in the cec settings the tv remote stops controlling the pi.


think thats a log i just made

We need a debug enabled log demonstrating the problem. Also please turn on component specific logging for cec.

my log here

how i obtained log:
tv and pi both are on
enable debug on pi
reboot pi
wait 30 seconds to make sure fully booted up
tv remote working ok with pi
switch tv off
wait 30 seconds
switch tv on
tv remote not working with pi anymore
switch tv to live channels input antenna
wait 30 seconds
switch tv to hdmi input pi
tv remote works with pi
saved logs and uploaded

steps to reproduce issue:

tv and pi both are on
tv remote works on pi
switch tv off
switch tv on
tv remote not working with pi
switch tv to other input (live tv antenna)
switch tv to hdmi input pi
tv remote works with pi


log of my pi not turning of my tv with cec component specific enabled


any updates on this?

i have since noticed if i use the exit button on kodi it turns the tv off as osmc closes and turns the tv back on when it re loads. but if i use the thut down button the tv does not turn off

I’ve noticed this on my daughter’s Visio. Does not happen on my Samsung

1 Like

You can disable this function in Settings>System>Input>Peripherals>CEC Adapter. It was probably a simple oversight that this was not disabled by default, I’ll make sure it’s looked into.

Yeah I don’t mind that it turned my TV off and on again on exit, my main problem is that it does not turn my TV off when I do the shutdown. And this shows the hardware does work

Same as bfunke. I use a Visio, and after the Krypton update, CEC is buggy at best. After a period of inactivity, where the screen dims, my remote no longer wakes up the system to do things. I have to turn the TV off, then on again, and then it will work. I tried everything I know how to do - reinstall, disable CEC then reenable it, etc. etc. I’m not offering a solution (I don’t know code-level stuff), but just trying to help by adding that I’m a Visio owner with the same issue. I also reinstalled the Confluence skin over v17; was that a mistake? The new skin is too confusing, so maybe my problem is reinstalling Confluence…???


well after the latest update my raspberry pi is still not turning my tv off via hdmi cec, and the epg genre for pvr tv still does not display colours based on the program genre.

gromgsxr, I couldn’t take it anymore - the turning on and off the TV whenever I would switch over to my RPi HDMI port. It was confusing to my wife and my kids, so I killed Kodi 17 and rolled it back to 16. Good as new.

And since I hate the new default skin and tried to install the Confluence skin over v17 anyway, rolling everything back to v16 made no difference to me except now everything works properly.

I don’t think 17 was ready for prime time.

osmc still is not turning my tv off when it shuts down, i have tried a fresh image and tried unplugging the tv, and the pi and it still does not want to play ball. it does power up the tv when osmc loads and the cec remote works fine. i can post logs later if they may shed some light on the situation.

Don’t forget component specific logging for cec.

still having the behaviour explained above, if i exit kodi my tv turns off, it turns back on when kodi re loads this one i can live with but my majour gripe is that osmc does not turn the tv off when it shuts down like it is set to. log: https://paste.osmc.tv/utahotilir

so i have posted logs on this twice and been patiently waiting for about 3 months now is there any chance someone can look in to this

after the latest update still the same problem can some one take a look at this please