CEC issues

Hi, something unusual is happening with the Vero’s CEC controls. If “when the tv is switched off = ignore” is set and the tv is switched off the Vero will switch off too. This happens even when the Vero isn’t the active source. Also, if then the tv is powered on, the Vero stays off.

My PC running LE with a Pulse 8 CEC adapter works properly, so if it’d help a dev I could post the adapter? (I’m in the UK).

Tv is a Loewe. I’ve tried also another which I know implements CEC properly, but had the same results.

It might be related to some of the odd CEC issues we saw around inactive source. I will check if there have been any improvements upstream, and if there have, I’ll make these changes available.

Which version of LE are you running? The CEC problems (which seem to affect both OSMC and LE) were introduced by Kodi Krypton which requires a newer version of libCEC. Annoyingly, the results were not consistent for everyone: some improvements caused regressions and vice versa.


Hi, it’s LE7.x. I can try out LE8 and report back if that’ll help?

If LE7 is working on your other device and you’re happy with it, it’s probably not a good idea to upgrade to see if the issue is also there.

But if you can test with a temporary install, it would be handy to know.
As far as I can see we have the same patches for some CEC quirks; so I wouldn’t expect
a difference in behaviour.


Updated to LE8 and all is working - power controls are fine, when changing source Kodi stops any playing video, etc.

Are you able to test without the P8 adapter?
P8 adapter is a reference design; if that makes sense.

Similarly: are you able to test with the P8 adapter on Vero 4K


Don’t have a PC to test that has onboard CEC, but a friend’s does so I’ll try that tomorrow.

Tried the adapter on the Vero. Made sure to switch off the internal CEC and select the adaptor. Still no joy - it keeps playing video when it’s no longer the active source, and switching the tv off causes the Vero to switch off.

If it helps - it’s not a tv issue, as it’s old one from work that the techs have analysed the output from.
Also, the adapter is libcec 4.0.2 with firmware v4.

OK – thanks for letting me know.
I’ll get back to you shortly with some suggestions. If you’re handy with the command line that will make things easier.


Thanks very much. I’m certainly not a linux expert but I’ll give it a go.