CEC LG Remote controller not working

HI. I have a RP1 since some time ago, attached to a LG TV. I previously had Raspbian with XBMC, and the TV remote controller worked out of the box.

Now i have installed a freshly new osmc, and everything works wonderfully except the controller, that is completely ignored.

I have activated the debug mode, and in the .kodi/temp/kodi.log i see this sequence of messages (repeated constantly each second)

23:06:39 T:2802316320  NOTICE: Thread JobWorker start, auto delete: true
23:06:45 T:3023938096  NOTICE: Log level changed to "LOG_LEVEL_DEBUG_FREEMEM"
23:06:45 T:3023938096  NOTICE: Enabled debug logging due to GUI setting. Level 2.
23:06:45 T:3023938096   DEBUG: ------ Window Init () ------
23:06:45 T:2910843936   DEBUG: CecLogMessage - << Recorder 1 (1) -> TV (0): POLL
23:06:45 T:2910843936   DEBUG: CecLogMessage - << 10
23:06:46 T:2910843936   DEBUG: Previous line repeats 1 times.
23:06:46 T:2910843936   DEBUG: CecLogMessage - >> POLL not sent

I have searched the forum for similar problems, but can’t manage to get it to work. I have switched off the TV and restarted the Raspberry, and unplugged the HDMI cable and plugged in other port. I cannot change the cable because I have only one. There is no other HDMI device connected to the TV.

Any clue, or other tests than I may do to further investigate the problem? If you want, i can upload the full kodi.log file.

Thanks very much.

In the tv’s menus, under simplink, is the pi even recognized?

It works now! The word “simplink” is what i was missing :grin: I didn’t know that LG calls this to the CEC technology. With a little searching in the web and in the TV menus, i’ve manage to turn symlink on and to configure the raspberry as a “PC” as seen from the TV, and now is working.

Thanks very much for the clue.


@hirunatan: how you configure the raspberry as a “PC” ??

I have the same problem with LG TV, cec doesn’t work, in the log i see TV(0) “not present”.

On the tv, simplink not recognize the raspberry PI 2.


My LG TV (5 years old) recognize my PI 2 via simplink. So you may want to try another HDMI cable.
On the other hand LG CEC is really bad only limited amount of keys are working.

@jeje69, the configuration i did was with the TV remote controller. It has a button labelled “symlink”, when pressed it shows a menu that allows me to specify what kind of device (PC, Game console, DVD Player…) is attached to each TV input port (HDMI1, VGA, etc.).

I have the RasPI attached to HDMI2, and the TV recognized it as a generic device; when I changed it to a “PC”, the remote controller started working.

Thanks for your answers.
I test 4 differents cables and i have the same result.
My TV is an LG 47LW659S and i don’t have simplink on the remote control, i have an acces to a simplink menu in input list menu from input key on the remote control.
this is my Simplink menu:

do you have the same menu ?

my next test is to pass the raspberry pi2 to a friend for a test on his TV, he don’t have an LG TV :smile:


Hi all,

The test conducted by my friend has failed also.
he has an panasonic TV, i think the problem come from the OSMC or libcec, there are incompatible with the PI2 or my hdmi PI2 has a problem.

If you have an idea…

CEC on the PI2 with OSMC works very well in general. There are some problems known with LG but none in they way that nothing works.

Sincerely, I don’t know anything more. My TV has a different simplink menu, in mine there is an option for “PC”.

CEC support on many LG TV’s (including mine) is pretty badly broken.

I have a 32" LG for a bedroom TV and CEC is not reliable either on my Pi 2 or My Fire TV Stick.

In both cases it works if I boot the Pi / Fire TV Stick while the TV is already on, but as soon as I put the TV in standby then wake it up again CEC stops working. No amount of fiddling in the menus will get it working again, the only things that work are either rebooting the Pi / Stick, or switching the TV to a different HDMI input then back again after the TV has been turned on - but because I don’t have any other HDMI inputs connected I cannot even do that.

So I don’t bother with CEC on that TV. On my Samsung TV CEC works perfectly every time with both devices.

Probably not what you want to hear but I think the general consensus is that CEC just doesn’t work properly on LG TV’s due to limitations of the TV itself.

hi, i need the same
what kind of configuration to see rpi 2 like a pc, with smart tv lg43uf671v

i user hdmi3 and allo go on without any customization


i have the same problem.
lg with pi2 and osmc.
my lg has 3 hdmi ports and cec on the pi only works if i disconnect the other 2 hdmi cables which are connected to a sattelite receiver and a virgin box.
i need to find a way to tell the tv to send the cec commands only to the pi or maybe to set the pi to always listen to the cec commands by default. any way to do that?

the same, only the 2nd hdmi port work with osmc …

I have a similar issue on my LG tv whit simplink:

My LG 49LF have 2 hdmi port… i have connected my Pi2 on hdmi2 and the simplinks working whitout a problems but if i restart OSMC and the Home it’s back on my TV the Remote it’s completely lost and CEC/Simplinks it’s no more working.

For fix this situation i need to switch one time the source on my TV… i need for example to switch to TV and immediatelly switch back to HDMI 2 and the LG Remote re-back to work whitout a problems!

I have also this problems if i switch to HDMI 2 before to switch on my Pi2… also in this situation when OSMC brigs on my TV i need to switch source one time for start to use LG Remote by simplinks!

The only ways it’s put on another source different by HDMI 2 (example HDMI 1 how it’s connect my Sky decoder) and turn on my Pi2. At this point when OSMC it’s turned on and home it’s brings on my TV it’s been autoswitched on HDMI 2 and LG Remote working whitout a problems…

My fist idea it’s to open a newest thread… but this thread it’s active between one month ago and if i can obtain some help here… thanks in advance.


Interesting… i have already a file edid.dat… it’s on /boot and on my config.txt i have already the two voices hdmi_force_hotplug=1 and hdmi_edid_file=1 but apparently it’s not resolve my problems.

Otherwise it’s similar but it’s not my exact trouble… i thinks i can try to explain step to step some situation :slight_smile:

  • Start whith TV turned ON and Pi2 turned off
  • on TV i stay to watch TV… i turn on my Pi2 and after about 10 seconds the TV swith automatically on “HDMI 2” (port where it’s connected my Pi2) and CEC working whitout problems.
  • I remain to watch “HDMI 2”…If now i restart OSMC (like for example after installing an upgrade or similar) when the home of OSMC it’s bring again on TV the CEC it’s no more working. For brings back to work i need to switch for example to another difference source and back again to “HDMI 2” and the CEC re-start to work

I have tryed to change some setting inside "Settings → Input device → CEC settings… i have tryed to disabled the “Auto-Switch Source” feature but in this way it’s even worse… try to explain:

  • Whit “Auto-Switch Source” feature disabled… if i put my TV first on “HDMI 2” and turn my Pi2 when OSMC brings on screen CEC it’s not working. I need to switch one time source on my tv and it’s start to works.
  • Whit “Auto-Switch Source” feature disabled… i need to stay watch TV… turn on my Pi2… wait about a 30 seconds (meantime osmc it’s completely boot) and now when i switch to “HDMI 2” CEC work from beginnings whitout any problems.
  • Whit “Auto-Switch Source” disabled the problems at restart of osmc it’s obtain similar result like whit “Auto-Swith source” activated…

Apparently the situation it’s completely different if i use the Auto-Switch feature or not… whit it disabled it’s more trouble infact i prefer to maintain this active because in this way the CEC stop to work only after a restart of osmc.

Hi all
I have the same problem, using the tv “LG Flatron M24500D - PZ” and osmc on RPi B (generation 1). (the remote has a code - “AKB72915217”)

I followed the wiki steps on 2.7 TV is not detected unless powered on first (as @ActionA suggested), then started the RPi having the tv on.
The file edid.dat is inside /boot/ and the /boot/config.txt is edited, but no success.

Any ideas on that ?
Is there somekind of mapping that I should do in order to “introduce” this remote to osmc ?
(forgive my questions, I am new to this and just want to solve this)

thanks in advance